toolchain/musl: update to 1.2.4
authorLinhui Liu <liulinhui36@gmail.com>
Sun, 7 May 2023 08:05:45 +0000 (16:05 +0800)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 15 May 2023 18:39:17 +0000 (20:39 +0200)
Release notes:

new features:
- large dns record lookups via tcp fallback
- new getaddrinfo EAI_NODATA result to distinguish NODATA/NxDomain
- support for new RELR compressed format for relative relocations
- sysconf keys for querying signal stack size requirements
- real vfork on riscv64

performance:
- mallocng no longer uses MADV_FREE (high performance cost, little gain)
- vdso clock_gettime is supported once again on 32-bit arm

compatibility:
- gethostbyname family now distinguishes NO_DATA from HOST_NOT_FOUND
- res_send now works with caller-provided edns0 queries
- arpa/nameser.h RR types list is now up-to-date
- previously-missing POSIX confstr keys have been added
- mntent interfaces now accept missing fields
- alt signal stack, if any, is now used for internal signals
- the LFS64 macros are no longer exposed without _LARGEFILE64_SOURCE
- memmem (POSIX-future) is now exposed in default feature profile
- pthread_atfork now admits calls from an application-provided malloc
- debugger tracking of shared libraries now works on MIPS PIE binaries
- sendmsg now supports up to SCM_MAX_FD fds in SCM_RIGHTS messages

bugs fixed:
- gethostbyname[2]_r wrongly returned nonzero (error) on negative result
- parallel v4/v6 address queries could fail on query id collisions
- spurious getaddrinfo/AI_ADDRCONFIG failures due to errno clobbering
- dns search domains ending in dot (including lone dot) broke lookups
- ipv6 servers in resolv.conf broke lookups on systems with v6 disabled
- systems with bindv6only failed to query both v4 and v6 nameservers
- res_mkquery mishandled consecutive final dots in name
- res_send could malfunction for very small answer buffer sizes
- resolver dns backend accepted answers with wrong (A vs AAAA) RR type
- getservbyport_r returned junk or ENOENT (vs ERANGE) on buffer size errors
- dns result parsing of malformed responses could process uninitialized data
- freopen didn't reset stream orientation (byte/wide) & encoding rule
- fwprintf didn't print most fields on open_wmemstream FILEs
- wide printf %lc ignored field width
- wide printf erroneously processed %n after encoding errors
- use of wide printf %9$ argument slot overflowed undersized buffer
- swprintf malfunctioned on nul character in output
- strverscmp ordered digit sequences vs nondigits incorrectly
- timer_create/SIGEV_THREAD failure leaked the thread
- semaphores were subject to missed-wake under certain usage patterns
- several possible rare deadlocks with lock handling at thread exit
- several possible rare deadlocks with aio and multithreaded fork
- dynamic linker relro processing was broken on archs w/variable pagesize
- async cancellation could run cancellation handlers in invalid context
- pthread_detach was wrongly a cancellation point in rare race code path
- use-after-close/double-close errors in mq_notify error paths
- mq_notify event thread wrongly ran with signals unmasked
- wcs{,n}cmp, wmemcmp returned wrong results when difference overflowed
- accept4, pipe2, and dup3 handled unknown flags wrong in fallback cases
- CPU_SETSIZE macro had wrong unit
- select fallback for pre-time64 kernels truncated timeout (vs clamping)

arch-specific bugs fixed:
- x32 new socketcalls took fallback path due to pointer sign extension
- x32 wait4 didn't fill rusage structure (time64 regression)
- x32 semtimedop mismatched timespec ABI with kernel (time64 regression)
- sigaction signal mask was bogus on or1k, microblaze, mips, and riscv
- powerpc-sf longjmp asm clobbered value argument
- or1k poll function passed timeout to syscall in wrong form

Removed upstreamed:
- 800-mips_pie_debug.patch
Manually rebased:
- 600-nftw-support-common-gnu-extension.patch

Signed-off-by: Linhui Liu <liulinhui36@gmail.com>
toolchain/musl/common.mk
toolchain/musl/patches/600-nftw-support-common-gnu-extension.patch
toolchain/musl/patches/800-mips_pie_debug.patch [deleted file]

index 040127c3bccdb62c9fcfbf7a7a5694a382d244bb..0901fe7d6f4d920436e57aa7fd2ddfff2d44e736 100644 (file)
@@ -8,12 +8,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=musl
-PKG_VERSION:=1.2.3
+PKG_VERSION:=1.2.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://musl.libc.org/releases/
-PKG_HASH:=7d5b0b6062521e4627e099e4c9dc8248d32a30285e959b7eecaa780cf8cfd4a4
+PKG_HASH:=7a35eae33d5372a7c0da1188de798726f68825513b7ae3ebe97aaaa52114f039
 
 LIBC_SO_VERSION:=$(PKG_VERSION)
 PATCH_DIR:=$(PATH_PREFIX)/patches
index 2a7436cf8489b4e376419d1d7064cb2935f0f7a6..7a1ab3f99a36196e525744a469fbbe862c8f1c5f 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Tony Ambardar <Tony.Ambardar@gmail.com>
  #include <ftw.h>
  #include <dirent.h>
  #include <fcntl.h>
-@@ -72,8 +73,20 @@ static int do_nftw(char *path, int (*fn)
+@@ -74,8 +75,20 @@ static int do_nftw(char *path, int (*fn)
                if (!fd_limit) close(dfd);
        }
  
@@ -56,7 +56,7 @@ Signed-off-by: Tony Ambardar <Tony.Ambardar@gmail.com>
  
        for (; h; h = h->chain)
                if (h->dev == st.st_dev && h->ino == st.st_ino)
-@@ -101,7 +114,10 @@ static int do_nftw(char *path, int (*fn)
+@@ -103,7 +116,10 @@ static int do_nftw(char *path, int (*fn)
                                strcpy(path+j+1, de->d_name);
                                if ((r=do_nftw(path, fn, fd_limit-1, flags, &new))) {
                                        closedir(d);
@@ -68,7 +68,7 @@ Signed-off-by: Tony Ambardar <Tony.Ambardar@gmail.com>
                                }
                        }
                        closedir(d);
-@@ -112,8 +128,16 @@ static int do_nftw(char *path, int (*fn)
+@@ -114,8 +130,16 @@ static int do_nftw(char *path, int (*fn)
        }
  
        path[l] = 0;
@@ -87,9 +87,9 @@ Signed-off-by: Tony Ambardar <Tony.Ambardar@gmail.com>
  
        return 0;
  }
-@@ -139,4 +163,5 @@ int nftw(const char *path, int (*fn)(con
+@@ -140,3 +164,5 @@ int nftw(const char *path, int (*fn)(con
+       pthread_setcancelstate(cs, 0);
        return r;
  }
++
 +#undef nftw64
- weak_alias(nftw, nftw64);
diff --git a/toolchain/musl/patches/800-mips_pie_debug.patch b/toolchain/musl/patches/800-mips_pie_debug.patch
deleted file mode 100644 (file)
index 80fe15e..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-Fix DT_DEBUG handling on MIPS in musl libc.
-With this change gdb will load the symbol files for shared libraries on MIPS too.
-
-This patch was taken from this thread: https://www.openwall.com/lists/musl/2022/01/09/4
-
---- a/arch/mips/reloc.h
-+++ b/arch/mips/reloc.h
-@@ -29,6 +29,7 @@
- #define NEED_MIPS_GOT_RELOCS 1
- #define DT_DEBUG_INDIRECT DT_MIPS_RLD_MAP
-+#define DT_DEBUG_INDIRECT_REL DT_MIPS_RLD_MAP_REL
- #define ARCH_SYM_REJECT_UND(s) (!((s)->st_other & STO_MIPS_PLT))
- #define CRTJMP(pc,sp) __asm__ __volatile__( \
---- a/arch/mips64/reloc.h
-+++ b/arch/mips64/reloc.h
-@@ -38,6 +38,7 @@
- #define NEED_MIPS_GOT_RELOCS 1
- #define DT_DEBUG_INDIRECT DT_MIPS_RLD_MAP
-+#define DT_DEBUG_INDIRECT_REL DT_MIPS_RLD_MAP_REL
- #define ARCH_SYM_REJECT_UND(s) (!((s)->st_other & STO_MIPS_PLT))
- #define CRTJMP(pc,sp) __asm__ __volatile__( \
---- a/arch/mipsn32/reloc.h
-+++ b/arch/mipsn32/reloc.h
-@@ -29,6 +29,7 @@
- #define NEED_MIPS_GOT_RELOCS 1
- #define DT_DEBUG_INDIRECT DT_MIPS_RLD_MAP
-+#define DT_DEBUG_INDIRECT_REL DT_MIPS_RLD_MAP_REL
- #define ARCH_SYM_REJECT_UND(s) (!((s)->st_other & STO_MIPS_PLT))
- #define CRTJMP(pc,sp) __asm__ __volatile__( \
---- a/ldso/dynlink.c
-+++ b/ldso/dynlink.c
-@@ -1923,6 +1923,10 @@ void __dls3(size_t *sp, size_t *auxv)
-                       size_t *ptr = (size_t *) app.dynv[i+1];
-                       *ptr = (size_t)&debug;
-               }
-+              if (app.dynv[i]==DT_DEBUG_INDIRECT_REL) {
-+                      size_t *ptr = (size_t *)((size_t)&app.dynv[i] + app.dynv[i+1]);
-+                      *ptr = (size_t)&debug;
-+              }
-       }
-       /* This must be done before final relocations, since it calls
---- a/src/internal/dynlink.h
-+++ b/src/internal/dynlink.h
-@@ -92,6 +92,10 @@ struct fdpic_dummy_loadmap {
- #define DT_DEBUG_INDIRECT 0
- #endif
-+#ifndef DT_DEBUG_INDIRECT_REL
-+#define DT_DEBUG_INDIRECT_REL 0
-+#endif
-+
- #define AUX_CNT 32
- #define DYN_CNT 32