lldpd: add option to disable custom TLVs
authorJohn Crispin <john@openwrt.org>
Wed, 3 Jun 2015 13:59:14 +0000 (13:59 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 3 Jun 2015 13:59:14 +0000 (13:59 +0000)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
SVN-Revision: 45884

package/network/services/lldpd/Config.in
package/network/services/lldpd/Makefile

index 448506d0473df6e255178cf8a59e46a7799b8874..93d84e29ea1af42de1e61174591361081643f07e 100644 (file)
@@ -41,6 +41,11 @@ config LLDPD_WITH_DOT3
        prompt "Enable Dot3 extension (PHY stuff)"
        default y
 
+config LLDPD_WITH_CUSTOM
+       bool
+       prompt "Enable Custom TLVs"
+       default y
+
 config LLDPD_WITH_JSON
        bool
        prompt "Enable JSON output for the LLDP Command-Line Interface"
index cccb9ba5d771d6844efa69df9580f9f26282c146..81e4a8ffb0d859f6d737344be4f01b5acfc1f4fc 100644 (file)
@@ -100,6 +100,7 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_LLDPD_WITH_LLDPMED),,--disable-lldpmed) \
        $(if $(CONFIG_LLDPD_WITH_DOT1),,--disable-dot1) \
        $(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
+       $(if $(CONFIG_LLDPD_WITH_CUSTOM),,--disable-custom) \
        $(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
        $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no)