base-files: /lib/functions.sh: ignore errors in insert_modules
authorMatthias Schiffer <mschiffer@universe-factory.net>
Tue, 17 Apr 2018 09:19:20 +0000 (11:19 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Tue, 17 Apr 2018 09:19:20 +0000 (11:19 +0200)
Package postinst will pass even names of builtin modules to insert_modules,
leading to postinst failing with error 255. This has been fixed in master
in r5279, but for lede-17.01 this minimal change is preferable.

Fixes FS#645, FS#893.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
package/base-files/Makefile
package/base-files/files/lib/functions.sh

index 40963d5bd4a7fce5834c4cd6aa6d5454662c063e..1d034fdede7598f15b1f802c47e834990e5852d9 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=173.5
+PKG_RELEASE:=173.6
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index bea5f0f96be1a2bc97899f50f2bca7cc19f9a9f3..c69feb33b8f73d3002d21a5e0f7b4d93fc936aef 100755 (executable)
@@ -158,7 +158,7 @@ insert_modules() {
                if [ -f /etc/modules.d/$m ]; then
                        sed 's/^[^#]/insmod &/' /etc/modules.d/$m | ash 2>&- || :
                else
-                       modprobe $m
+                       modprobe $m || :
                fi
        done
 }