brcm47xx: add brcmsmac + bgmac profile
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 12 Jan 2014 19:04:54 +0000 (19:04 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 12 Jan 2014 19:04:54 +0000 (19:04 +0000)
Signed-off-by: Cody P Schafer <devel@codyps.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 39258

target/linux/brcm47xx/profiles/226-Broadcom-bgmac-brcsmac.mk [new file with mode: 0644]

diff --git a/target/linux/brcm47xx/profiles/226-Broadcom-bgmac-brcsmac.mk b/target/linux/brcm47xx/profiles/226-Broadcom-bgmac-brcsmac.mk
new file mode 100644 (file)
index 0000000..d9dc9e7
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-bgmac-brcmsmac
+  NAME:=Broadcom SoC, bgmac Ethernet, BCM43xx WiFi (brcmsmac)
+  PACKAGES:=kmod-bgmac kmod-brcmsmac
+endef
+
+define Profile/Broadcom-bgmac-brcmsmac/Description
+       Package set compatable with newer gigabit + N based bcm47xx SoCs with
+       Broadcom BCM43xx Wifi cards using the mac80211 brcmsmac driver and
+       bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-bgmac-brcmsmac))
+