ifxmips-dsl-control: move to $(KERNEL_BUILD_DIR), add $(LINUX_DIR)/include to cflags
authorFelix Fietkau <nbd@openwrt.org>
Sun, 28 Mar 2010 21:42:07 +0000 (21:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 28 Mar 2010 21:42:07 +0000 (21:42 +0000)
SVN-Revision: 20557

package/ifxmips-dsl-control/Makefile

index 90cefd259911a3f65760d53b67004ce57829efe6..035deada147c1d629d1aaad2cd154a772f0bb7a3 100644 (file)
@@ -7,6 +7,7 @@
 # ralph / blogic
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_BASE_NAME:=dsl_cpe_control_danube
 PKG_VERSION:=3.24.4.4
@@ -73,6 +74,8 @@ CONFIGURE_ARGS += \
        --enable-soap-support
 endif
 
+TARGET_CFLAGS += -I$(LINUX_DIR)/include
+
 define Package/ifxmips-dsl-control/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/ifx_cpe_control_init.sh $(1)/etc/init.d/