refresh 2.6.30 kernel patches
authorFlorian Fainelli <florian@openwrt.org>
Fri, 30 Oct 2009 16:24:52 +0000 (16:24 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 30 Oct 2009 16:24:52 +0000 (16:24 +0000)
SVN-Revision: 18231

target/linux/rdc/patches-2.6.30/001-rdc3210_flash_map.patch
target/linux/rdc/patches-2.6.30/003-rootfstype.patch
target/linux/rdc/patches-2.6.30/005-fix_amit_breakage.patch
target/linux/rdc/patches-2.6.30/008-r8610_flash_map.patch
target/linux/rdc/patches-2.6.30/009-rdc321x_select_embedded.patch

index 2c35b841a307b60ccfad2e2f28c6b4038956ea8e..d1ac2e7b671d0c8e7b8cf79f71c1e0d8853421c0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/maps/Kconfig
 +++ b/drivers/mtd/maps/Kconfig
-@@ -112,6 +112,50 @@ config MTD_SUN_UFLASH
+@@ -123,6 +123,50 @@ config MTD_SUN_UFLASH
          Sun Microsystems boardsets.  This driver will require CFI support
          in the kernel, so if you did not enable CFI previously, do that now.
  
index 386e638971d4af1480e1b5b0824620cdb4692aca..e7ed527cac8cd14a51c6000ed19b7b36688f9242 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/do_mounts.c
 +++ b/init/do_mounts.c
-@@ -189,6 +189,8 @@ static void __init get_fs_names(char *pa
+@@ -191,6 +191,8 @@ static void __init get_fs_names(char *pa
  {
        char *s = page;
  
index 8103e841d527645e979766dd42320a3b12937f76..92bce802bf5c554eec4cbca15017a01626a1e193 100644 (file)
@@ -21,7 +21,7 @@
  
  /*
   * Invoke the realmode switch hook if present; otherwise
-@@ -156,6 +159,16 @@ void go_to_protected_mode(void)
+@@ -112,6 +115,16 @@ void go_to_protected_mode(void)
                die();
        }
  
index e0ccb83ccc68b009057be2bccb3f7f95e739ced5..b374c0616cbbc601780259b9f73e4c45344a5dd0 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.29.5/drivers/mtd/maps/Kconfig
-===================================================================
---- linux-2.6.29.5.orig/drivers/mtd/maps/Kconfig       2009-06-19 11:26:44.000000000 +0200
-+++ linux-2.6.29.5/drivers/mtd/maps/Kconfig    2009-06-19 11:26:45.000000000 +0200
-@@ -167,6 +167,12 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -167,6 +167,12 @@ config MTD_RDC3210_BUSWIDTH
          Number of bytes addressed on the RDC-3210 flash device before
          addressing the same chip again
  
@@ -15,11 +13,9 @@ Index: linux-2.6.29.5/drivers/mtd/maps/Kconfig
  config MTD_SC520CDP
        tristate "CFI Flash device mapped on AMD SC520 CDP"
        depends on X86 && MTD_CFI && MTD_CONCAT
-Index: linux-2.6.29.5/drivers/mtd/maps/Makefile
-===================================================================
---- linux-2.6.29.5.orig/drivers/mtd/maps/Makefile      2009-06-19 11:26:44.000000000 +0200
-+++ linux-2.6.29.5/drivers/mtd/maps/Makefile   2009-06-19 11:26:45.000000000 +0200
-@@ -28,6 +28,7 @@
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM)   += pmcms
  obj-$(CONFIG_MTD_PMC_MSP_RAMROOT)+= pmcmsp-ramroot.o
  obj-$(CONFIG_MTD_PCMCIA)      += pcmciamtd.o
  obj-$(CONFIG_MTD_RDC3210)     += rdc3210.o
index 84ab6c5c22731ab10170373ac1d7b826df0253d2..0e0e1192b348e06313a4e53aaea7456412a97e21 100644 (file)
@@ -1,6 +1,6 @@
---- a/arch/x86/Kconfig 2009-06-19 15:06:16.000000000 +0200
-+++ b/arch/x86/Kconfig 2009-06-19 15:06:01.000000000 +0200
-@@ -380,6 +380,7 @@
+--- a/arch/x86/Kconfig
++++ b/arch/x86/Kconfig
+@@ -380,6 +380,7 @@ config X86_RDC321X
        depends on X86_EXTENDED_PLATFORM
        select M486
        select X86_REBOOTFIXUPS