Fix the stage2 compilation, no side effect with gcc4 (#2190)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 13 Aug 2007 16:26:58 +0000 (16:26 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 13 Aug 2007 16:26:58 +0000 (16:26 +0000)
SVN-Revision: 8409

toolchain/gcc/Makefile

index cd18098e9fb5d2cc4aaa1e9f1cf8e0d40dfa41d1..bae9220f0c220821101e6e6a0e13d72bc4b71a31 100644 (file)
@@ -93,9 +93,7 @@ define Stage2/Configure
 endef
 
 define Stage2/Compile
 endef
 
 define Stage2/Compile
-       $(MAKE) -C $(BUILD_DIR2) \
-               SHELL="$(BASH)" \
-               all
+       export SHELL="\$(BASH)"; \$(MAKE) -C \$(BUILD_DIR2) all
 endef
 
 define Stage2/Install
 endef
 
 define Stage2/Install