ixp4xx: Rename fsg3 subtarget to harddisk to better reflect the intention of the...
authorRod Whitby <rod@whitby.id.au>
Fri, 7 Dec 2007 22:30:56 +0000 (22:30 +0000)
committerRod Whitby <rod@whitby.id.au>
Fri, 7 Dec 2007 22:30:56 +0000 (22:30 +0000)
SVN-Revision: 9670

target/linux/ixp4xx/Makefile
target/linux/ixp4xx/fsg3/config-default [deleted file]
target/linux/ixp4xx/fsg3/profiles/100-FSG3.mk [deleted file]
target/linux/ixp4xx/fsg3/target.mk [deleted file]
target/linux/ixp4xx/harddisk/config-default [new file with mode: 0644]
target/linux/ixp4xx/harddisk/profiles/100-FSG3.mk [new file with mode: 0644]
target/linux/ixp4xx/harddisk/target.mk [new file with mode: 0644]

index 5b9d3fb551413af6ad88ddb989d9edeaad52a640..6dd22114dcb3cb4d0bdb4bf6146070f7e90e0e5b 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=armeb
 BOARD:=ixp4xx
 BOARDNAME:=Intel XScale IXP4xx
 FEATURES:=squashfs
-SUBTARGETS=generic fsg3
+SUBTARGETS=generic harddisk
 
 LINUX_VERSION:=2.6.21.6
 
diff --git a/target/linux/ixp4xx/fsg3/config-default b/target/linux/ixp4xx/fsg3/config-default
deleted file mode 100644 (file)
index 6dfaae0..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-CONFIG_CMDLINE="root=/dev/sda1 noinitrd console=ttyS0,115200"
-CONFIG_ATA=y
-CONFIG_SATA_VIA=y
-CONFIG_USB_ARCH_HAS_HCD=y
-CONFIG_USB_ARCH_HAS_OHCI=y
-CONFIG_USB_ARCH_HAS_EHCI=y
-CONFIG_USB=y
-CONFIG_USB_EHCI_HCD=y
-CONFIG_USB_EHCI_SPLIT_ISO=y
-CONFIG_USB_EHCI_ROOT_HUB_TT=y
-CONFIG_USB_EHCI_TT_NEWSCHED=y
-CONFIG_USB_OHCI_HCD=y
-CONFIG_USB_OHCI_LITTLE_ENDIAN=y
-CONFIG_USB_STORAGE=y
-CONFIG_EXT3_FS=y
-CONFIG_EXT3_FS_XATTR=y
-CONFIG_EXT3_FS_POSIX_ACL=y
-CONFIG_EXT3_FS_SECURITY=y
-CONFIG_JBD=y
-CONFIG_FS_MBCACHE=y
-CONFIG_BLK_DEV_SD=y
-CONFIG_REISERFS_FS=y
diff --git a/target/linux/ixp4xx/fsg3/profiles/100-FSG3.mk b/target/linux/ixp4xx/fsg3/profiles/100-FSG3.mk
deleted file mode 100644 (file)
index f06fa8c..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/FSG3
-  NAME:=Freecom FSG-3
-  PACKAGES:= \
-       kmod-madwifi wireless-tools \
-       kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
-       kmod-fs-ext2 kmod-fs-reiserfs
-endef
-
-define Profile/FSG3/Description
-       Package set optimized for the Freecom FSG-3
-endef
-$(eval $(call Profile,FSG3))
-
diff --git a/target/linux/ixp4xx/fsg3/target.mk b/target/linux/ixp4xx/fsg3/target.mk
deleted file mode 100644 (file)
index c71065e..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-BOARDNAME:=Internal Hard-Disk
-
-define Target/Description
-       Build firmware images for ixp4xx based boards that boot directly from internal disk storage
-       (e.g : Freecom FSG-3, ...)
-endef
diff --git a/target/linux/ixp4xx/harddisk/config-default b/target/linux/ixp4xx/harddisk/config-default
new file mode 100644 (file)
index 0000000..6dfaae0
--- /dev/null
@@ -0,0 +1,22 @@
+CONFIG_CMDLINE="root=/dev/sda1 noinitrd console=ttyS0,115200"
+CONFIG_ATA=y
+CONFIG_SATA_VIA=y
+CONFIG_USB_ARCH_HAS_HCD=y
+CONFIG_USB_ARCH_HAS_OHCI=y
+CONFIG_USB_ARCH_HAS_EHCI=y
+CONFIG_USB=y
+CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_EHCI_SPLIT_ISO=y
+CONFIG_USB_EHCI_ROOT_HUB_TT=y
+CONFIG_USB_EHCI_TT_NEWSCHED=y
+CONFIG_USB_OHCI_HCD=y
+CONFIG_USB_OHCI_LITTLE_ENDIAN=y
+CONFIG_USB_STORAGE=y
+CONFIG_EXT3_FS=y
+CONFIG_EXT3_FS_XATTR=y
+CONFIG_EXT3_FS_POSIX_ACL=y
+CONFIG_EXT3_FS_SECURITY=y
+CONFIG_JBD=y
+CONFIG_FS_MBCACHE=y
+CONFIG_BLK_DEV_SD=y
+CONFIG_REISERFS_FS=y
diff --git a/target/linux/ixp4xx/harddisk/profiles/100-FSG3.mk b/target/linux/ixp4xx/harddisk/profiles/100-FSG3.mk
new file mode 100644 (file)
index 0000000..f06fa8c
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FSG3
+  NAME:=Freecom FSG-3
+  PACKAGES:= \
+       kmod-madwifi wireless-tools \
+       kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
+       kmod-fs-ext2 kmod-fs-reiserfs
+endef
+
+define Profile/FSG3/Description
+       Package set optimized for the Freecom FSG-3
+endef
+$(eval $(call Profile,FSG3))
+
diff --git a/target/linux/ixp4xx/harddisk/target.mk b/target/linux/ixp4xx/harddisk/target.mk
new file mode 100644 (file)
index 0000000..c71065e
--- /dev/null
@@ -0,0 +1,6 @@
+BOARDNAME:=Internal Hard-Disk
+
+define Target/Description
+       Build firmware images for ixp4xx based boards that boot directly from internal disk storage
+       (e.g : Freecom FSG-3, ...)
+endef