Remove patch-cmdline from the packages and move it tools tools/. adm5120 and rb532...
authorFlorian Fainelli <florian@openwrt.org>
Sun, 1 Jul 2007 09:45:27 +0000 (09:45 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 1 Jul 2007 09:45:27 +0000 (09:45 +0000)
SVN-Revision: 7820

package/patch-cmdline/Makefile [deleted file]
package/patch-cmdline/src/patch-cmdline.c [deleted file]
target/linux/adm5120-2.6/image/Makefile
target/linux/rb532-2.6/image/Makefile
tools/Makefile
tools/patch-cmdline/Makefile [new file with mode: 0644]
tools/patch-cmdline/src/patch-cmdline.c [new file with mode: 0644]

diff --git a/package/patch-cmdline/Makefile b/package/patch-cmdline/Makefile
deleted file mode 100644 (file)
index 70dc1ea..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id: $
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=patch-cmdline
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/patch-cmdline
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=Patch the kernel command line for RouterBoards
-  DEPENDS:=@LINUX_2_6_ADM5120||@LINUX_2_6_RB532
-  DESCRIPTION:=\
-       A tool to patch the kernel command line on RouterBoards
-  URL:=https://dev.openwrt.org/browser/trunk/package/patch-cmdline/src/patch-cmdline.c
-  VERSION:=1
-endef
-
-define Build/Prepare
-       $(CP) ./src/$(PKG_NAME).c $(PKG_BUILD_DIR)/
-endef
-
-define Build/Compile
-       $(TARGET_CC) -o $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_BUILD_DIR)/$(PKG_NAME).c
-endef
-
-define Package/patch-cmdline/install
-       $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/sbin/
-endef
-
-$(eval $(call BuildPackage,patch-cmdline))
diff --git a/package/patch-cmdline/src/patch-cmdline.c b/package/patch-cmdline/src/patch-cmdline.c
deleted file mode 100644 (file)
index d4636f7..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-/*
- * patch-cmdline.c - patch the kernel command line on rb532
- *
- * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
- *
- * This program is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License
- * as published by the Free Software Foundation; either version 2
- * of the License, or (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
- *
- * $Id:$
- */
-
-#include <stdio.h>
-#include <stdlib.h>
-#include <stddef.h>
-#include <unistd.h>
-#include <fcntl.h>
-#include <sys/mman.h>
-#include <sys/stat.h>
-#include <string.h>
-
-#define SEARCH_SPACE   (16 * 1024)
-#define CMDLINE_MAX            512
-
-int main(int argc, char **argv)
-{
-       int fd, found = 0, len, ret = -1;
-       char *ptr, *p;
-
-       if (argc != 3) {
-               fprintf(stderr, "Usage: %s <file> <cmdline>\n", argv[0]);
-               goto err1;
-       }
-       len = strlen(argv[2]);
-       if (len + 9 > CMDLINE_MAX) {
-               fprintf(stderr, "Command line string too long\n");
-               goto err1;
-       }
-       
-       if (((fd = open(argv[1], O_RDWR)) < 0) ||
-               (ptr = (char *) mmap(0, SEARCH_SPACE + CMDLINE_MAX, PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0)) == (void *) (-1)) {
-               fprintf(stderr, "Could not open kernel image");
-               goto err2;
-       }
-       
-       for (p = ptr; p < (ptr + SEARCH_SPACE); p += 4) {
-               if (memcmp(p, "CMDLINE:", 8) == 0) {
-                       found = 1;
-                       p += 8;
-                       break;
-               }
-       }
-       if (!found) {
-               fprintf(stderr, "Command line marker not found!\n");
-               goto err3;
-       }
-
-       memset(p, 0, CMDLINE_MAX - 8);
-       strcpy(p, argv[2]);
-       msync(p, CMDLINE_MAX, MS_SYNC|MS_INVALIDATE);
-       ret = 0;
-
-err3:
-       munmap((void *) ptr, len);
-err2:
-       if (fd > 0)
-               close(fd);
-err1:
-       return ret;
-}
index 360a87f657810257442b5cf9873fdc4ddf0914e6..ae869f60553a15cba2b01d1bf8bfdd74bda10de6 100644 (file)
@@ -77,8 +77,13 @@ define Image/Build/MyLoader
                $(IMGNAME)-$(3)-$(2).bin
 endef
 
+define Image/cmdline/yaffs2
+root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
+endef
+
 define Image/Build/RouterBoard
        $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-vmlinux
+       $(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/yaffs2)) '
 endef
 
 define Image/Build
index 84f37e3bb2cff0430ab6aa23e9d71c90c7bfc01c..555eb2a645cd841be61009a71de6af3c644c317b 100644 (file)
@@ -20,10 +20,6 @@ LOADER_MAKEOPTS= \
                RAMSIZE=$(RAMSIZE) \
                IMAGE_COPY=$(IMAGE_COPY)
 
-define Build/Compile
-       $(CC) -o $(STAGING_DIR)/bin/patch-cmdline $(PLATFORM_DIR)/src/patch-cmdline.c
-endef
-
 define Build/Clean
        $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
 endef
index 4ee3f1ae7e5eabd458ccf61a52c7d0076ce63ff2..68e7dab534f0ce6f6aef3563aa20baabad20136f 100644 (file)
@@ -7,7 +7,7 @@
 # Main makefile for the host tools
 #
 include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
+TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline
 TARGETS-$(CONFIG_CCACHE) += ccache
 
 TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
diff --git a/tools/patch-cmdline/Makefile b/tools/patch-cmdline/Makefile
new file mode 100644 (file)
index 0000000..75ea7b5
--- /dev/null
@@ -0,0 +1,34 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=patch-cmdline
+
+PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+OS:=$(shell uname)
+ifeq ($(HOST_OS),Darwin)
+  CFLAGS += -I./include
+endif
+CFLAGS += -I $(TOPDIR)/tools/include -include endian.h
+
+define Build/Compile
+       $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/$(PKG_NAME) src/$(PKG_NAME).c
+endef
+
+define Build/Install
+       mkdir -p $(STAGING_DIR)/bin
+       $(CP) $(PKG_BUILD_DIR)/patch-cmdline $(STAGING_DIR)/bin/
+endef
+
+define Build/Clean
+       -rm -f $(STAGING_DIR)/bin/patch-cmdline
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/patch-cmdline/src/patch-cmdline.c b/tools/patch-cmdline/src/patch-cmdline.c
new file mode 100644 (file)
index 0000000..d4636f7
--- /dev/null
@@ -0,0 +1,80 @@
+/*
+ * patch-cmdline.c - patch the kernel command line on rb532
+ *
+ * Copyright (C) 2006 Felix Fietkau <nbd@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
+ *
+ * $Id:$
+ */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <stddef.h>
+#include <unistd.h>
+#include <fcntl.h>
+#include <sys/mman.h>
+#include <sys/stat.h>
+#include <string.h>
+
+#define SEARCH_SPACE   (16 * 1024)
+#define CMDLINE_MAX            512
+
+int main(int argc, char **argv)
+{
+       int fd, found = 0, len, ret = -1;
+       char *ptr, *p;
+
+       if (argc != 3) {
+               fprintf(stderr, "Usage: %s <file> <cmdline>\n", argv[0]);
+               goto err1;
+       }
+       len = strlen(argv[2]);
+       if (len + 9 > CMDLINE_MAX) {
+               fprintf(stderr, "Command line string too long\n");
+               goto err1;
+       }
+       
+       if (((fd = open(argv[1], O_RDWR)) < 0) ||
+               (ptr = (char *) mmap(0, SEARCH_SPACE + CMDLINE_MAX, PROT_READ|PROT_WRITE, MAP_SHARED, fd, 0)) == (void *) (-1)) {
+               fprintf(stderr, "Could not open kernel image");
+               goto err2;
+       }
+       
+       for (p = ptr; p < (ptr + SEARCH_SPACE); p += 4) {
+               if (memcmp(p, "CMDLINE:", 8) == 0) {
+                       found = 1;
+                       p += 8;
+                       break;
+               }
+       }
+       if (!found) {
+               fprintf(stderr, "Command line marker not found!\n");
+               goto err3;
+       }
+
+       memset(p, 0, CMDLINE_MAX - 8);
+       strcpy(p, argv[2]);
+       msync(p, CMDLINE_MAX, MS_SYNC|MS_INVALIDATE);
+       ret = 0;
+
+err3:
+       munmap((void *) ptr, len);
+err2:
+       if (fd > 0)
+               close(fd);
+err1:
+       return ret;
+}