add gcc 4.3.3, clean up gcc version config symbols
authorFelix Fietkau <nbd@openwrt.org>
Tue, 27 Jan 2009 20:08:34 +0000 (20:08 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 27 Jan 2009 20:08:34 +0000 (20:08 +0000)
SVN-Revision: 14226

toolchain/gcc/Config.in
toolchain/gcc/Config.version
toolchain/gcc/Makefile

index 8d91ba2c5425560a3bf385e681f68649d4d196d8..40042ee82b37e6d82387cb0eb692380bfc488dd6 100644 (file)
@@ -30,6 +30,10 @@ choice
                depends !LINUX_2_4
                bool "gcc 4.3.2"
 
+       config GCC_VERSION_4_3_3
+               depends !LINUX_2_4
+               bool "gcc 4.3.3"
+
 endchoice
 
 config EABI_SUPPORT
index e822445bd688af3bac65af19f39cdd6da28fa99a..52feb5c0d454d49d48112ec8ef5d2deb818cb721 100644 (file)
@@ -5,6 +5,7 @@ config GCC_VERSION
        default "4.2.4"     if GCC_VERSION_4_2_4
        default "4.3.1"     if GCC_VERSION_4_3_1
        default "4.3.2"     if GCC_VERSION_4_3_2
+       default "4.3.3"     if GCC_VERSION_4_3_3
        default "4.1.2"
 
 config GCC_VERSION_3
@@ -17,10 +18,9 @@ config GCC_VERSION_3_4
        
 config GCC_VERSION_4
        bool
-       default y       if GCC_VERSION_4_1_2
-       default y       if GCC_VERSION_4_2_4
-       default y       if GCC_VERSION_4_3_1
-       default y       if GCC_VERSION_4_3_2
+       default y       if GCC_VERSION_4_1
+       default y       if GCC_VERSION_4_2
+       default y       if GCC_VERSION_4_3
 
 config GCC_VERSION_4_1
        bool
@@ -34,6 +34,7 @@ config GCC_VERSION_4_3
        bool
        default y       if GCC_VERSION_4_3_1
        default y       if GCC_VERSION_4_3_2
+       default y       if GCC_VERSION_4_3_3
 
 if !TOOLCHAINOPTS
        config GCC_VERSION_3_4_6
index 9a364eb8e152d3066c93a32cc84c53674b4615d6..0198e4364165e87e9f2af2243e5a042a6314fd3d 100644 (file)
@@ -41,6 +41,9 @@ endif
 ifeq ($(PKG_VERSION),4.3.2)
   PKG_MD5SUM:=5dfac5da961ecd5f227c3175859a486d
 endif
+ifeq ($(PKG_VERSION),4.3.3)
+  PKG_MD5SUM:=cc3c5565fdb9ab87a05ddb106ba0bd1f
+endif
 
 PATCH_DIR=./patches/$(PKG_VERSION)