Add new warning to help track down pesky compile issues
authorMike Baker <mbm@openwrt.org>
Wed, 30 Aug 2006 09:57:57 +0000 (09:57 +0000)
committerMike Baker <mbm@openwrt.org>
Wed, 30 Aug 2006 09:57:57 +0000 (09:57 +0000)
SVN-Revision: 4713

openwrt/include/package.mk

index 3328332725a4aa1aa5913d45370d016da0850d83..311ec35a9c1ebf3b36a1c6fb4c27ab5d370e2a47 100644 (file)
@@ -27,7 +27,9 @@ define Build/DefaultTargets
       endif
 
       ifneq ($(MAKECMDGOALS),prereq)
-        $$(info Rebuilding $$(_INFO))
+        ifneq ($$(_INFO),)
+          $$(info Rebuilding $$(_INFO))
+        endif
       endif
     endif
   endif
@@ -129,6 +131,10 @@ define BuildPackage
 
     ifneq ($(CONFIG_PACKAGE_$(1)),)
       compile-targets: $$(IPKG_$(1))
+    else
+      compile-targets: $(1)-disabled
+      $(1)-disabled:
+       @echo "WARNING: skipping $(1) -- package not selected"
     endif
   endif