kernel: add some more additional missing config symbols for 3.2 and 3.3
authorJonas Gorski <jogo@openwrt.org>
Mon, 9 Apr 2012 14:48:46 +0000 (14:48 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 9 Apr 2012 14:48:46 +0000 (14:48 +0000)
SVN-Revision: 31221

package/kernel/modules/block.mk
package/kernel/modules/netdevices.mk
package/kernel/modules/video.mk
target/linux/generic/config-3.2
target/linux/generic/config-3.3

index 88dcf1cccd075c596276a7a0faa68eb67c0e6087..d529d0ebaacf2cdfa691d5d5f7453f9988c8e8e1 100644 (file)
@@ -608,7 +608,9 @@ define KernelPackage/mvsas
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Marvell 88SE6440 SAS/SATA driver
   DEPENDS:=@TARGET_x86 +kmod-libsas
-  KCONFIG:=CONFIG_SCSI_MVSAS
+  KCONFIG:= \
+       CONFIG_SCSI_MVSAS \
+       CONFIG_SCSI_MVSAS_TASKLET=n
   ifneq ($(CONFIG_LINUX_2_6_30),)
        FILES:=$(LINUX_DIR)/drivers/scsi/mvsas.ko
   else
index ac9795b62321632460fa830505fcd4f3da1ac5cb..16fd93198dd4e9a628305a778ef8455ebad3bf72 100644 (file)
@@ -27,7 +27,8 @@ define KernelPackage/skge
   TITLE:=SysKonnect Yukon support
   DEPENDS:=@TARGET_x86
   KCONFIG:=CONFIG_SKGE \
-    CONFIG_SKGE_DEBUG=n
+       CONFIG_SKGE_DEBUG=n \
+       CONFIG_SKGE_GENESIS=n
   ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.2)),1)
     FILES:=$(LINUX_DIR)/drivers/net/ethernet/marvell/skge.ko
   else
index 892f045b47c5006a0b9456c651a7f2226fca3918..d75005938c6036dd2c0f89b4daf3f3936a892577 100644 (file)
@@ -20,7 +20,8 @@ define KernelPackage/video-core
        CONFIG_VIDEO_CAPTURE_DRIVERS=y \
        CONFIG_V4L_USB_DRIVERS=y \
        CONFIG_V4L_PCI_DRIVERS=y \
-       CONFIG_V4L_PLATFORM_DRIVERS=y
+       CONFIG_V4L_PLATFORM_DRIVERS=y \
+       CONFIG_V4L_ISA_PARPORT_DRIVERS=y
 ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
   FILES:= \
        $(LINUX_DIR)/drivers/media/video/v4l2-common.ko \
index 033e8322696014cf458cf694e54601c8882a65e4..f1ca2d2be4e3b3c8b4a537e19f1ffd490148ea17 100644 (file)
@@ -8,6 +8,7 @@ CONFIG_32BIT=y
 # CONFIG_ABX500_CORE is not set
 # CONFIG_ACCESSIBILITY is not set
 # CONFIG_ACENIC is not set
+# CONFIG_ACERHDF is not set
 # CONFIG_ACORN_PARTITION is not set
 # CONFIG_ACPI_APEI is not set
 # CONFIG_ACPI_CUSTOM_METHOD is not set
@@ -164,6 +165,7 @@ CONFIG_ATM_CLIP_NO_ICMP=y
 CONFIG_BASE_FULL=y
 CONFIG_BASE_SMALL=0
 # CONFIG_BATMAN_ADV is not set
+# CONFIG_BATTERY_BQ20Z75 is not set
 # CONFIG_BATTERY_BQ27x00 is not set
 # CONFIG_BATTERY_DS2760 is not set
 # CONFIG_BATTERY_DS2780 is not set
@@ -590,6 +592,7 @@ CONFIG_DEVPORT=y
 # CONFIG_E100 is not set
 # CONFIG_E1000 is not set
 # CONFIG_E1000E is not set
+# CONFIG_E2100 is not set
 # CONFIG_EASYCAP is not set
 # CONFIG_ECHO is not set
 # CONFIG_ECONET is not set
@@ -601,6 +604,8 @@ CONFIG_DEVPORT=y
 # CONFIG_EEPROM_DIGSY_MTC_CFG is not set
 # CONFIG_EEPROM_LEGACY is not set
 # CONFIG_EEPROM_MAX6875 is not set
+# CONFIG_EEXPRESS is not set
+# CONFIG_EEXPRESS_PRO is not set
 CONFIG_EFI_PARTITION=y
 # CONFIG_EFS_FS is not set
 # CONFIG_ELF_CORE is not set
@@ -614,10 +619,12 @@ CONFIG_ENABLE_WARN_DEPRECATED=y
 CONFIG_EPOLL=y
 # CONFIG_EQUALIZER is not set
 # CONFIG_ET131X is not set
+# CONFIG_ETH16I is not set
 CONFIG_ETHERNET=y
 # CONFIG_ETHOC is not set
 # CONFIG_EARLY_PRINTK is not set
 CONFIG_EVENTFD=y
+# CONFIG_EWRK3 is not set
 CONFIG_EXPERIMENTAL=y
 CONFIG_EXPERT=y
 # CONFIG_EXPORTFS is not set
@@ -863,6 +870,8 @@ CONFIG_HOTPLUG=y
 # CONFIG_HOTPLUG_PCI is not set
 # CONFIG_HP100 is not set
 # CONFIG_HPFS_FS is not set
+# CONFIG_HPLAN is not set
+# CONFIG_HPLAN_PLUS is not set
 # CONFIG_HP_ILO is not set
 # CONFIG_HTC_EGPIO is not set
 # CONFIG_HTC_I2CPLD is not set
@@ -1317,6 +1326,7 @@ CONFIG_LOCKD_V4=y
 # CONFIG_LOGO is not set
 CONFIG_LOG_BUF_SHIFT=14
 # CONFIG_LOONGSON_MC146818 is not set
+# CONFIG_LP486E is not set
 # CONFIG_LPC_SCH is not set
 # CONFIG_LP_CONSOLE is not set
 # CONFIG_LSI_ET1011C_PHY is not set
@@ -1580,6 +1590,7 @@ CONFIG_MTD_ROOTFS_SPLIT=y
 # CONFIG_NATSEMI is not set
 # CONFIG_NCP_FS is not set
 # CONFIG_NE2K_PCI is not set
+# CONFIG_NE2000 is not set
 # CONFIG_NEC_MARKEINS is not set
 CONFIG_NET=y
 # CONFIG_NETCONSOLE is not set
@@ -1747,6 +1758,7 @@ CONFIG_NET_VENDOR_ATHEROS=y
 CONFIG_NET_VENDOR_BROADCOM=y
 CONFIG_NET_VENDOR_BROCADE=y
 CONFIG_NET_VENDOR_CHELSIO=y
+CONFIG_NET_VENDOR_CIRRUS=y
 CONFIG_NET_VENDOR_CISCO=y
 CONFIG_NET_VENDOR_DEC=y
 CONFIG_NET_VENDOR_DLINK=y
@@ -1836,6 +1848,8 @@ CONFIG_NFS_V3=y
 # CONFIG_NF_NAT_SIP is not set
 # CONFIG_NF_NAT_SNMP_BASIC is not set
 # CONFIG_NF_NAT_TFTP is not set
+# CONFIG_NI52 is not set
+# CONFIG_NI65 is not set
 # CONFIG_NILFS2_FS is not set
 # CONFIG_NIU is not set
 CONFIG_NLATTR=y
@@ -2395,6 +2409,7 @@ CONFIG_SELECT_MEMORY_MODEL=y
 # CONFIG_SENSORS_I5K_AMB is not set
 # CONFIG_SENSORS_IT87 is not set
 # CONFIG_SENSORS_JC42 is not set
+# CONFIG_SENSORS_K10TEMP is not set
 # CONFIG_SENSORS_K8TEMP is not set
 # CONFIG_SENSORS_LINEAGE is not set
 # CONFIG_SENSORS_LIS3LV02D is not set
@@ -2445,6 +2460,7 @@ CONFIG_SELECT_MEMORY_MODEL=y
 # CONFIG_SENSORS_TMP421 is not set
 # CONFIG_SENSORS_TSL2550 is not set
 # CONFIG_SENSORS_VIA686A is not set
+# CONFIG_SENSORS_VIA_CPUTEMP is not set
 # CONFIG_SENSORS_VT1211 is not set
 # CONFIG_SENSORS_VT8231 is not set
 # CONFIG_SENSORS_W83627EHF is not set
@@ -2525,6 +2541,7 @@ CONFIG_SLABINFO=y
 # CONFIG_SLUB_STATS is not set
 # CONFIG_SMARTJOYPLUS_FF is not set
 # CONFIG_SMC911X is not set
+# CONFIG_SMC9194 is not set
 # CONFIG_SMC91X is not set
 # CONFIG_SMP is not set
 # CONFIG_SMSC911X is not set
@@ -2860,6 +2877,7 @@ CONFIG_UDF_NLS=y
 CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug"
 # CONFIG_UFS_FS is not set
 # CONFIG_UIO is not set
+# CONFIG_ULTRA is not set
 # CONFIG_ULTRIX_PARTITION is not set
 CONFIG_UNIX=y
 CONFIG_UNIX98_PTYS=y
@@ -3269,6 +3287,7 @@ CONFIG_VMSPLIT_3G=y
 CONFIG_WATCHDOG=y
 # CONFIG_WATCHDOG_CORE is not set
 # CONFIG_WATCHDOG_NOWAYOUT is not set
+# CONFIG_WD80x3 is not set
 # CONFIG_WDTPCI is not set
 CONFIG_WEXT_CORE=y
 CONFIG_WEXT_PRIV=y
index 9578f15a8dca38b3ebec581dc355f5cdef327754..06eeb90bc22568ee81906bab5878e8d7442ee0b7 100644 (file)
@@ -8,6 +8,7 @@ CONFIG_32BIT=y
 # CONFIG_ABX500_CORE is not set
 # CONFIG_ACCESSIBILITY is not set
 # CONFIG_ACENIC is not set
+# CONFIG_ACERHDF is not set
 # CONFIG_ACORN_PARTITION is not set
 # CONFIG_ACPI_APEI is not set
 # CONFIG_ACPI_CUSTOM_METHOD is not set
@@ -32,6 +33,7 @@ CONFIG_AIO=y
 # CONFIG_ALTERA_STAPL is not set
 # CONFIG_AMD8111_ETH is not set
 # CONFIG_AMIGA_PARTITION is not set
+# CONFIG_AMILO_RFKILL is not set
 # CONFIG_ANDROID is not set
 CONFIG_ANON_INODES=y
 # CONFIG_APDS9802ALS is not set
@@ -173,6 +175,7 @@ CONFIG_BASE_SMALL=0
 # CONFIG_BATTERY_DS2782 is not set
 # CONFIG_BATTERY_MAX17040 is not set
 # CONFIG_BATTERY_MAX17042 is not set
+# CONFIG_BATTERY_SBS is not set
 # CONFIG_BAYCOM_EPP is not set
 # CONFIG_BAYCOM_PAR is not set
 # CONFIG_BAYCOM_SER_FDX is not set
@@ -360,6 +363,7 @@ CONFIG_CAVIUM_OCTEON_HELPER=y
 # CONFIG_CFG80211 is not set
 # CONFIG_CGROUPS is not set
 # CONFIG_CHARGER_GPIO is not set
+# CONFIG_CHARGER_LP8727 is not set
 # CONFIG_CHARGER_MAX8903 is not set
 # CONFIG_CHECKPOINT_RESTORE is not set
 # CONFIG_CHELSIO_T1 is not set
@@ -598,6 +602,7 @@ CONFIG_DQL=y
 # CONFIG_E100 is not set
 # CONFIG_E1000 is not set
 # CONFIG_E1000E is not set
+# CONFIG_E2100 is not set
 # CONFIG_EASYCAP is not set
 # CONFIG_ECHO is not set
 # CONFIG_ECONET is not set
@@ -609,6 +614,8 @@ CONFIG_DQL=y
 # CONFIG_EEPROM_DIGSY_MTC_CFG is not set
 # CONFIG_EEPROM_LEGACY is not set
 # CONFIG_EEPROM_MAX6875 is not set
+# CONFIG_EEXPRESS is not set
+# CONFIG_EEXPRESS_PRO is not set
 CONFIG_EFI_PARTITION=y
 # CONFIG_EFS_FS is not set
 # CONFIG_ELF_CORE is not set
@@ -622,9 +629,11 @@ CONFIG_ENABLE_WARN_DEPRECATED=y
 CONFIG_EPOLL=y
 # CONFIG_EQUALIZER is not set
 # CONFIG_ET131X is not set
+# CONFIG_ETH16I is not set
 CONFIG_ETHERNET=y
 # CONFIG_ETHOC is not set
 CONFIG_EVENTFD=y
+# CONFIG_EWRK3 is not set
 CONFIG_EXPERIMENTAL=y
 CONFIG_EXPERT=y
 # CONFIG_EXPORTFS is not set
@@ -737,6 +746,7 @@ CONFIG_FSNOTIFY=y
 # CONFIG_FTRACE is not set
 # CONFIG_FTRACE_STARTUP_TEST is not set
 # CONFIG_FTR_FIXUP_SELFTEST is not set
+# CONFIG_FUJITSU_TABLET is not set
 # CONFIG_FUNCTION_TRACER is not set
 # CONFIG_FUSE_FS is not set
 # CONFIG_FUSION is not set
@@ -869,6 +879,8 @@ CONFIG_HOTPLUG=y
 # CONFIG_HOTPLUG_PCI is not set
 # CONFIG_HP100 is not set
 # CONFIG_HPFS_FS is not set
+# CONFIG_HPLAN is not set
+# CONFIG_HPLAN_PLUS is not set
 # CONFIG_HP_ILO is not set
 # CONFIG_HTC_EGPIO is not set
 # CONFIG_HTC_I2CPLD is not set
@@ -1329,6 +1341,7 @@ CONFIG_LOCKD_V4=y
 # CONFIG_LOGO is not set
 CONFIG_LOG_BUF_SHIFT=14
 # CONFIG_LOONGSON_MC146818 is not set
+# CONFIG_LP486E is not set
 # CONFIG_LPC_SCH is not set
 # CONFIG_LP_CONSOLE is not set
 # CONFIG_LSI_ET1011C_PHY is not set
@@ -1595,6 +1608,7 @@ CONFIG_MTD_ROOTFS_SPLIT=y
 # CONFIG_NATIONAL_PHY is not set
 # CONFIG_NATSEMI is not set
 # CONFIG_NCP_FS is not set
+# CONFIG_NE2000 is not set
 # CONFIG_NE2K_PCI is not set
 # CONFIG_NEC_MARKEINS is not set
 CONFIG_NET=y
@@ -1768,6 +1782,7 @@ CONFIG_NET_VENDOR_ATHEROS=y
 CONFIG_NET_VENDOR_BROADCOM=y
 CONFIG_NET_VENDOR_BROCADE=y
 CONFIG_NET_VENDOR_CHELSIO=y
+CONFIG_NET_VENDOR_CIRRUS=y
 CONFIG_NET_VENDOR_CISCO=y
 CONFIG_NET_VENDOR_DEC=y
 CONFIG_NET_VENDOR_DLINK=y
@@ -1858,6 +1873,8 @@ CONFIG_NFS_V3=y
 # CONFIG_NF_NAT_SIP is not set
 # CONFIG_NF_NAT_SNMP_BASIC is not set
 # CONFIG_NF_NAT_TFTP is not set
+# CONFIG_NI52 is not set
+# CONFIG_NI65 is not set
 # CONFIG_NILFS2_FS is not set
 # CONFIG_NIU is not set
 CONFIG_NLATTR=y
@@ -2421,6 +2438,7 @@ CONFIG_SELECT_MEMORY_MODEL=y
 # CONFIG_SENSORS_I5K_AMB is not set
 # CONFIG_SENSORS_IT87 is not set
 # CONFIG_SENSORS_JC42 is not set
+# CONFIG_SENSORS_K10TEMP is not set
 # CONFIG_SENSORS_K8TEMP is not set
 # CONFIG_SENSORS_LINEAGE is not set
 # CONFIG_SENSORS_LIS3LV02D is not set
@@ -2471,6 +2489,7 @@ CONFIG_SELECT_MEMORY_MODEL=y
 # CONFIG_SENSORS_TMP421 is not set
 # CONFIG_SENSORS_TSL2550 is not set
 # CONFIG_SENSORS_VIA686A is not set
+# CONFIG_SENSORS_VIA_CPUTEMP is not set
 # CONFIG_SENSORS_VT1211 is not set
 # CONFIG_SENSORS_VT8231 is not set
 # CONFIG_SENSORS_W83627EHF is not set
@@ -2550,6 +2569,7 @@ CONFIG_SLABINFO=y
 # CONFIG_SLUB_STATS is not set
 # CONFIG_SMARTJOYPLUS_FF is not set
 # CONFIG_SMC911X is not set
+# CONFIG_SMC9194 is not set
 # CONFIG_SMC91X is not set
 # CONFIG_SMP is not set
 # CONFIG_SMSC911X is not set
@@ -2884,6 +2904,7 @@ CONFIG_UDF_NLS=y
 CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug"
 # CONFIG_UFS_FS is not set
 # CONFIG_UIO is not set
+# CONFIG_ULTRA is not set
 # CONFIG_ULTRIX_PARTITION is not set
 CONFIG_UNIX=y
 # CONFIG_UNIX_DIAG is not set
@@ -3299,6 +3320,7 @@ CONFIG_VMSPLIT_3G=y
 CONFIG_WATCHDOG=y
 # CONFIG_WATCHDOG_CORE is not set
 # CONFIG_WATCHDOG_NOWAYOUT is not set
+# CONFIG_WD80x3 is not set
 # CONFIG_WDTPCI is not set
 CONFIG_WEXT_CORE=y
 CONFIG_WEXT_PRIV=y