hci_h4p: Compile fixes
authorMichael Büsch <mb@bu3sch.de>
Thu, 7 Oct 2010 13:05:31 +0000 (13:05 +0000)
committerMichael Büsch <mb@bu3sch.de>
Thu, 7 Oct 2010 13:05:31 +0000 (13:05 +0000)
SVN-Revision: 23291

target/linux/omap24xx/patches-2.6.36/400-bluetooth-hci_h4p.patch

index 6c5cfc4054e0bc75c66632002faa56ff02e16fdb..85dd928e8aa85748fb426da9fb5df9f97e28242b 100644 (file)
@@ -2,18 +2,18 @@
  drivers/bluetooth/Kconfig           |   10 
  drivers/bluetooth/Makefile          |    1 
  drivers/bluetooth/hci_h4p/Makefile  |    7 
- drivers/bluetooth/hci_h4p/core.c    | 1023 ++++++++++++++++++++++++++++++++++++
+ drivers/bluetooth/hci_h4p/core.c    | 1043 ++++++++++++++++++++++++++++++++++++
  drivers/bluetooth/hci_h4p/fw-csr.c  |  149 +++++
  drivers/bluetooth/hci_h4p/fw-ti.c   |   90 +++
  drivers/bluetooth/hci_h4p/fw.c      |  155 +++++
  drivers/bluetooth/hci_h4p/hci_h4p.h |  183 ++++++
  drivers/bluetooth/hci_h4p/sysfs.c   |   84 ++
  drivers/bluetooth/hci_h4p/uart.c    |  169 +++++
- 10 files changed, 1871 insertions(+)
+ 10 files changed, 1891 insertions(+)
 
 --- /dev/null
-+++ linux-2.6.36-rc4/drivers/bluetooth/hci_h4p/core.c
-@@ -0,0 +1,1023 @@
++++ linux-2.6.36-rc7/drivers/bluetooth/hci_h4p/core.c
+@@ -0,0 +1,1043 @@
 +/*
 + * This file is part of hci_h4p bluetooth driver
 + *
@@ -55,7 +55,7 @@
 +#include <mach/hardware.h>
 +#include <mach/board.h>
 +#include <mach/irqs.h>
-+//#include <mach/pm.h>
++#include <plat/serial.h>
 +
 +#include <net/bluetooth/bluetooth.h>
 +#include <net/bluetooth/hci_core.h>
 +      }
 +      info->hdev = hdev;
 +
-+      hdev->type = HCI_UART;
++      hdev->dev_type = HCI_UART;
 +      hdev->driver_data = info;
 +
 +      hdev->open = hci_h4p_hci_open;
 +      gpio_direction_output(info->bt_wakeup_gpio, 0);
 +      gpio_direction_input(info->host_wakeup_gpio);
 +
++//FIXME
++#if defined(CONFIG_ARCH_OMAP1)
++# define OMAP_UART1_BASE      OMAP1_UART1_BASE
++# define OMAP_UART2_BASE      OMAP1_UART2_BASE
++# define OMAP_UART3_BASE      OMAP1_UART3_BASE
++#elif defined(CONFIG_ARCH_OMAP2)
++# define OMAP_UART1_BASE      OMAP2_UART1_BASE
++# define OMAP_UART2_BASE      OMAP2_UART2_BASE
++# define OMAP_UART3_BASE      OMAP2_UART3_BASE
++#elif defined(CONFIG_ARCH_OMAP3)
++# define OMAP_UART1_BASE      OMAP3_UART1_BASE
++# define OMAP_UART2_BASE      OMAP3_UART2_BASE
++# define OMAP_UART3_BASE      OMAP3_UART3_BASE
++#elif defined(CONFIG_ARCH_OMAP4)
++# define OMAP_UART1_BASE      OMAP4_UART1_BASE
++# define OMAP_UART2_BASE      OMAP4_UART2_BASE
++# define OMAP_UART3_BASE      OMAP4_UART3_BASE
++#else
++# error
++#endif
 +      switch (bt_config->bt_uart) {
 +      case 1:
 +              if (cpu_is_omap16xx()) {
 +MODULE_LICENSE("GPL");
 +MODULE_AUTHOR("Ville Tervo");
 --- /dev/null
-+++ linux-2.6.36-rc4/drivers/bluetooth/hci_h4p/fw.c
++++ linux-2.6.36-rc7/drivers/bluetooth/hci_h4p/fw.c
 @@ -0,0 +1,155 @@
 +/*
 + * This file is part of hci_h4p bluetooth driver
 +      return;
 +}
 --- /dev/null
-+++ linux-2.6.36-rc4/drivers/bluetooth/hci_h4p/fw-csr.c
++++ linux-2.6.36-rc7/drivers/bluetooth/hci_h4p/fw-csr.c
 @@ -0,0 +1,149 @@
 +/*
 + * This file is part of hci_h4p bluetooth driver
 +      return 0;
 +}
 --- /dev/null
-+++ linux-2.6.36-rc4/drivers/bluetooth/hci_h4p/fw-ti.c
++++ linux-2.6.36-rc7/drivers/bluetooth/hci_h4p/fw-ti.c
 @@ -0,0 +1,90 @@
 +/*
 + * This file is part of hci_h4p bluetooth driver
 +      return 0;
 +}
 --- /dev/null
-+++ linux-2.6.36-rc4/drivers/bluetooth/hci_h4p/hci_h4p.h
++++ linux-2.6.36-rc7/drivers/bluetooth/hci_h4p/hci_h4p.h
 @@ -0,0 +1,183 @@
 +/*
 + * This file is part of hci_h4p bluetooth driver
 +
 +#endif /* __DRIVERS_BLUETOOTH_HCI_H4P_H */
 --- /dev/null
-+++ linux-2.6.36-rc4/drivers/bluetooth/hci_h4p/Makefile
++++ linux-2.6.36-rc7/drivers/bluetooth/hci_h4p/Makefile
 @@ -0,0 +1,7 @@
 +#
 +# Makefile for the Linux Bluetooth HCI device drivers.
 +
 +hci_h4p-objs := core.o fw.o uart.o sysfs.o fw-ti.o fw-csr.o
 --- /dev/null
-+++ linux-2.6.36-rc4/drivers/bluetooth/hci_h4p/sysfs.c
++++ linux-2.6.36-rc7/drivers/bluetooth/hci_h4p/sysfs.c
 @@ -0,0 +1,84 @@
 +/*
 + * This file is part of hci_h4p bluetooth driver
 +
 +#endif
 --- /dev/null
-+++ linux-2.6.36-rc4/drivers/bluetooth/hci_h4p/uart.c
++++ linux-2.6.36-rc7/drivers/bluetooth/hci_h4p/uart.c
 @@ -0,0 +1,169 @@
 +/*
 + * This file is part of hci_h4p bluetooth driver
 +
 +      return 0;
 +}
---- linux-2.6.36-rc4.orig/drivers/bluetooth/Kconfig
-+++ linux-2.6.36-rc4/drivers/bluetooth/Kconfig
+--- linux-2.6.36-rc7.orig/drivers/bluetooth/Kconfig
++++ linux-2.6.36-rc7/drivers/bluetooth/Kconfig
 @@ -173,6 +173,16 @@ config BT_HCIBTUART
          Say Y here to compile support for HCI UART devices into the
          kernel or say M to compile it as module (btuart_cs).
  config BT_HCIVHCI
        tristate "HCI VHCI (Virtual HCI device) driver"
        help
---- linux-2.6.36-rc4.orig/drivers/bluetooth/Makefile
-+++ linux-2.6.36-rc4/drivers/bluetooth/Makefile
+--- linux-2.6.36-rc7.orig/drivers/bluetooth/Makefile
++++ linux-2.6.36-rc7/drivers/bluetooth/Makefile
 @@ -11,6 +11,7 @@ obj-$(CONFIG_BT_HCIDTL1)     += dtl1_cs.o
  obj-$(CONFIG_BT_HCIBT3C)      += bt3c_cs.o
  obj-$(CONFIG_BT_HCIBLUECARD)  += bluecard_cs.o