ramips: print image build warnings/errors to stderr
authorJonas Gorski <jogo@openwrt.org>
Thu, 21 Feb 2013 11:45:33 +0000 (11:45 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 21 Feb 2013 11:45:33 +0000 (11:45 +0000)
Makes warnings/errors visible when building with V=w/V=1.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 35721

target/linux/ramips/image/Makefile

index 75f0e50d649eb994e0361476d620414831812770..d88bc95edb976882cd10e2817c80664d16cb6883 100644 (file)
@@ -63,9 +63,9 @@ endef
 define MkCombineduImage
        $(call PatchKernelLzma,$(2),$(3))
        if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt `expr $(4) - 64` ]; then \
-               echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
+               echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big" >&2; \
        else if [ `stat -c%s "$(KDIR)/root.$(1)"` -gt $(5) ]; then \
-               echo "Warning: $(KDIR)/root.$(1) is too big"; \
+               echo "Warning: $(KDIR)/root.$(1) is too big" >&2; \
        else \
                ( dd if=$(KDIR)/vmlinux-$(2).bin.lzma bs=`expr $(4) - 64` conv=sync ; dd if=$(KDIR)/root.$(1) ) > $(KDIR)/vmlinux-$(2).bin.lzma.combined ; \
        fi ; fi
@@ -74,9 +74,9 @@ endef
 
 define CatFiles
        if [ `stat -c%s "$(1)"` -gt $(2) ]; then \
-               echo "Warning: $(1) is too big"; \
+               echo "Warning: $(1) is too big" >&2; \
        else if [ `stat -c%s $(3)` -gt $(4) ]; then \
-               echo "Warning: $(3) is too big"; \
+               echo "Warning: $(3) is too big" >&2; \
        else \
                ( dd if=$(1) bs=$(2) conv=sync; dd if=$(3) ) > $(5); \
        fi; fi
@@ -319,9 +319,9 @@ endef
 define BuildFirmware/Seama
        $(call PatchKernelLzma,$(2),$(3))
        if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt $(4) ]; then \
-               echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
+               echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big" >&2; \
        else if [ `stat -c%s $(KDIR)/root.$(1)` -gt $(5) ]; then \
-               echo "Warning: $(KDIR)/root.$(1) is too big"; \
+               echo "Warning: $(KDIR)/root.$(1) is too big" >&2; \
        else \
                ( \
                        dd if=$(KDIR)/vmlinux-$(2).bin.lzma bs=$(4) count=1 conv=sync; \