clean up Gateway 7001 support
authorImre Kaloz <kaloz@openwrt.org>
Mon, 2 Apr 2007 14:41:10 +0000 (14:41 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 2 Apr 2007 14:41:10 +0000 (14:41 +0000)
SVN-Revision: 6829

target/linux/ixp4xx-2.6/patches/200-gateway_7001.patch
target/linux/ixp4xx-2.6/patches/210-gateway_7001_mac_setup.patch

index b672e5a5d82b48ab86c6fa093e5128e530205977..8112bb8892172748a6005f8bdec1cd25081ccde9 100644 (file)
@@ -1,6 +1,6 @@
 diff -Nur linux-2.6.19.2/arch/arm/boot/compressed/head-xscale.S linux-2.6.19.2-owrt/arch/arm/boot/compressed/head-xscale.S
 --- linux-2.6.19.2/arch/arm/boot/compressed/head-xscale.S      2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-owrt/arch/arm/boot/compressed/head-xscale.S 2007-03-03 22:42:42.000000000 +0100
++++ linux-2.6.19.2-owrt/arch/arm/boot/compressed/head-xscale.S 2007-04-02 15:39:28.000000000 +0200
 @@ -46,6 +46,11 @@
                 orr     r7, r7, #(MACH_TYPE_GTWX5715 & 0xff00)
  #endif
@@ -13,44 +13,9 @@ diff -Nur linux-2.6.19.2/arch/arm/boot/compressed/head-xscale.S linux-2.6.19.2-o
  #ifdef CONFIG_ARCH_IXP2000
                mov     r1, #-1
                mov     r0, #0xd6000000
-diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/coyote-setup.c linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/coyote-setup.c
---- linux-2.6.19.2/arch/arm/mach-ixp4xx/coyote-setup.c 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/coyote-setup.c    2007-03-03 23:33:35.000000000 +0100
-@@ -1,9 +1,10 @@
- /*
-  * arch/arm/mach-ixp4xx/coyote-setup.c
-  *
-- * Board setup for ADI Engineering and IXDGP425 boards
-+ * Board setup for ADI Engineering, IXDGP425 and Gateway 7001 boards
-  *
-  * Copyright (C) 2003-2005 MontaVista Software, Inc.
-+ * Copyright (C) 2006 Imre Kaloz <Kaloz@openwrt.org>
-  *
-  * Author: Deepak Saxena <dsaxena@plexity.net>
-  */
-@@ -111,6 +112,19 @@
- MACHINE_END
- #endif
-+#ifdef CONFIG_MACH_GATEWAY7001
-+MACHINE_START(GATEWAY7001, "Gateway 7001 AP")
-+      /* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
-+      .phys_io        = IXP4XX_PERIPHERAL_BASE_PHYS,
-+      .io_pg_offst    = ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xfffc,
-+      .map_io         = ixp4xx_map_io,
-+      .init_irq       = ixp4xx_init_irq,
-+      .timer          = &ixp4xx_timer,
-+      .boot_params    = 0x0100,
-+      .init_machine   = coyote_init,
-+MACHINE_END
-+#endif
-+
- /*
-  * IXDPG425 is identical to Coyote except for which serial port
-  * is connected.
 diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/gateway7001-pci.c linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/gateway7001-pci.c
 --- linux-2.6.19.2/arch/arm/mach-ixp4xx/gateway7001-pci.c      1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/gateway7001-pci.c 2007-03-03 22:42:42.000000000 +0100
++++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/gateway7001-pci.c 2007-04-02 15:39:28.000000000 +0200
 @@ -0,0 +1,68 @@
 +/*
 + * arch/arch/mach-ixp4xx/gateway7001-pci.c
@@ -120,9 +85,121 @@ diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/gateway7001-pci.c linux-2.6.19.2-o
 +}
 +
 +subsys_initcall(gateway7001_pci_init);
+diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/gateway7001-setup.c linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/gateway7001-setup.c
+--- linux-2.6.19.2/arch/arm/mach-ixp4xx/gateway7001-setup.c    1970-01-01 01:00:00.000000000 +0100
++++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/gateway7001-setup.c       2007-04-02 15:49:28.000000000 +0200
+@@ -0,0 +1,108 @@
++/*
++ * arch/arm/mach-ixp4xx/gateway7001-setup.c
++ *
++ * Board setup for the Gateway 7001 board
++ *
++ * Copyright (C) 2006 Imre Kaloz <Kaloz@openwrt.org>
++ *
++ * based on coyote-setup.c:
++ *      Copyright (C) 2003-2005 MontaVista Software, Inc.
++ *
++ * Author: Imre Kaloz <Kaloz@openwrt.org>
++ */
++
++#include <linux/kernel.h>
++#include <linux/init.h>
++#include <linux/device.h>
++#include <linux/serial.h>
++#include <linux/tty.h>
++#include <linux/serial_8250.h>
++#include <linux/slab.h>
++
++#include <asm/types.h>
++#include <asm/setup.h>
++#include <asm/memory.h>
++#include <asm/hardware.h>
++#include <asm/irq.h>
++#include <asm/mach-types.h>
++#include <asm/mach/arch.h>
++#include <asm/mach/flash.h>
++
++static struct flash_platform_data gateway7001_flash_data = {
++      .map_name       = "cfi_probe",
++      .width          = 2,
++};
++
++static struct resource gateway7001_flash_resource = {
++      .flags          = IORESOURCE_MEM,
++};
++
++static struct platform_device gateway7001_flash = {
++      .name           = "IXP4XX-Flash",
++      .id             = 0,
++      .dev            = {
++              .platform_data = &gateway7001_flash_data,
++      },
++      .num_resources  = 1,
++      .resource       = &gateway7001_flash_resource,
++};
++
++static struct resource gateway7001_uart_resource = {
++      .start  = IXP4XX_UART2_BASE_PHYS,
++      .end    = IXP4XX_UART2_BASE_PHYS + 0x0fff,
++      .flags  = IORESOURCE_MEM,
++};
++
++static struct plat_serial8250_port gateway7001_uart_data[] = {
++      {
++              .mapbase        = IXP4XX_UART2_BASE_PHYS,
++              .membase        = (char *)IXP4XX_UART2_BASE_VIRT + REG_OFFSET,
++              .irq            = IRQ_IXP4XX_UART2,
++              .flags          = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
++              .iotype         = UPIO_MEM,
++              .regshift       = 2,
++              .uartclk        = IXP4XX_UART_XTAL,
++      },
++      { },
++};
++
++static struct platform_device gateway7001_uart = {
++      .name           = "serial8250",
++      .id             = PLAT8250_DEV_PLATFORM,
++      .dev                    = {
++              .platform_data  = gateway7001_uart_data,
++      },
++      .num_resources  = 1,
++      .resource       = &gateway7001_uart_resource,
++};
++
++static struct platform_device *gateway7001_devices[] __initdata = {
++      &gateway7001_flash,
++      &gateway7001_uart
++};
++
++static void __init gateway7001_init(void)
++{
++      ixp4xx_sys_init();
++
++      gateway7001_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
++      gateway7001_flash_resource.end = IXP4XX_EXP_BUS_BASE(0) + SZ_32M - 1;
++
++      *IXP4XX_EXP_CS0 |= IXP4XX_FLASH_WRITABLE;
++      *IXP4XX_EXP_CS1 = *IXP4XX_EXP_CS0;
++
++      platform_add_devices(gateway7001_devices, ARRAY_SIZE(gateway7001_devices));
++}
++
++#ifdef CONFIG_MACH_GATEWAY7001
++MACHINE_START(GATEWAY7001, "Gateway 7001 AP")
++      /* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
++      .phys_io        = IXP4XX_PERIPHERAL_BASE_PHYS,
++      .io_pg_offst    = ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xfffc,
++      .map_io         = ixp4xx_map_io,
++      .init_irq       = ixp4xx_init_irq,
++      .timer          = &ixp4xx_timer,
++      .boot_params    = 0x0100,
++      .init_machine   = gateway7001_init,
++MACHINE_END
++#endif
 diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/Kconfig linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Kconfig
 --- linux-2.6.19.2/arch/arm/mach-ixp4xx/Kconfig        2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Kconfig   2007-03-03 22:42:42.000000000 +0100
++++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Kconfig   2007-04-02 15:39:28.000000000 +0200
 @@ -33,6 +33,14 @@
          Engineering Coyote Gateway Reference Platform. For more
          information on this platform, see <file:Documentation/arm/IXP4xx>.
@@ -140,23 +217,31 @@ diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/Kconfig linux-2.6.19.2-owrt/arch/a
        help
 diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/Makefile linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Makefile
 --- linux-2.6.19.2/arch/arm/mach-ixp4xx/Makefile       2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Makefile  2007-03-03 22:42:42.000000000 +0100
-@@ -20,5 +20,6 @@
++++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Makefile  2007-04-02 15:49:49.000000000 +0200
+@@ -11,6 +11,7 @@
+ obj-pci-$(CONFIG_MACH_GTWX5715)               += gtwx5715-pci.o
+ obj-pci-$(CONFIG_MACH_NSLU2)          += nslu2-pci.o
+ obj-pci-$(CONFIG_MACH_NAS100D)                += nas100d-pci.o
++obj-pci-$(CONFIG_MACH_GATEWAY7001)    += gateway7001-pci.o
+ obj-y += common.o
+@@ -20,5 +21,6 @@
  obj-$(CONFIG_MACH_GTWX5715)   += gtwx5715-setup.o
  obj-$(CONFIG_MACH_NSLU2)      += nslu2-setup.o nslu2-power.o
  obj-$(CONFIG_MACH_NAS100D)    += nas100d-setup.o nas100d-power.o
-+obj-$(CONFIG_MACH_GATEWAY7001)        += gateway7001-pci.o coyote-setup.o
++obj-$(CONFIG_MACH_GATEWAY7001)        += gateway7001-setup.o
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
 diff -Nur linux-2.6.19.2/include/asm-arm/arch-ixp4xx/uncompress.h linux-2.6.19.2-owrt/include/asm-arm/arch-ixp4xx/uncompress.h
 --- linux-2.6.19.2/include/asm-arm/arch-ixp4xx/uncompress.h    2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2-owrt/include/asm-arm/arch-ixp4xx/uncompress.h       2007-03-03 22:42:42.000000000 +0100
++++ linux-2.6.19.2-owrt/include/asm-arm/arch-ixp4xx/uncompress.h       2007-04-02 15:42:04.000000000 +0200
 @@ -38,9 +38,9 @@
  static __inline__ void __arch_decomp_setup(unsigned long arch_id)
  {
        /*
 -       * Coyote and gtwx5715 only have UART2 connected
-+       * Some boards only have UART2 connected
++       * Some boards are using UART2 as console
         */
 -      if (machine_is_adi_coyote() || machine_is_gtwx5715())
 +      if (machine_is_adi_coyote() || machine_is_gtwx5715() || machine_is_gateway7001())
index 2cf3bd2aa746cc1111dc7749ba35e78212d1499f..8b3f4b92c5aedd581109ec160095f6db0e114b93 100644 (file)
@@ -1,8 +1,8 @@
-diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/coyote-setup.c linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/coyote-setup.c
---- linux-2.6.19.2/arch/arm/mach-ixp4xx/coyote-setup.c 2007-03-03 23:34:46.000000000 +0100
-+++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/coyote-setup.c    2007-03-03 23:42:47.000000000 +0100
-@@ -74,9 +74,57 @@
-       .resource       = &coyote_uart_resource,
+diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/gateway7001-setup.c linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/gateway7001-setup.c
+--- linux-2.6.19.2/arch/arm/mach-ixp4xx/gateway7001-setup.c    2007-04-02 15:56:39.000000000 +0200
++++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/gateway7001-setup.c       2007-04-02 15:57:38.000000000 +0200
+@@ -76,9 +76,57 @@
+       .resource       = &gateway7001_uart_resource,
  };
  
 +static struct resource res_mac0 = {
@@ -51,12 +51,12 @@ diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/coyote-setup.c linux-2.6.19.2-owrt
 +      .resource       = &res_mac1,
 +};
 +
- static struct platform_device *coyote_devices[] __initdata = {
-       &coyote_flash,
--      &coyote_uart
-+      &coyote_uart,
+ static struct platform_device *gateway7001_devices[] __initdata = {
+       &gateway7001_flash,
+-      &gateway7001_uart
++      &gateway7001_uart,
 +      &mac0,
 +      &mac1,
  };
  
- static void __init coyote_init(void)
+ static void __init gateway7001_init(void)