Revert "[toolchain/eglibc} eglibc in fact can be built with -Os"
authorMirko Vogt <mirko@openwrt.org>
Mon, 20 Jun 2011 11:12:46 +0000 (11:12 +0000)
committerMirko Vogt <mirko@openwrt.org>
Mon, 20 Jun 2011 11:12:46 +0000 (11:12 +0000)
Compiling with -Os results in: "error: #error "glibc cannot be compiled without optimization"

Still, building with -Os is listed as feature in
<http://www.eglibc.org/features>:

""
Building with -Os
     EGLIBC supports building the library with compiler optimizing for size -Os instead of for speed -O2.
""

SVN-Revision: 27245

toolchain/eglibc/Makefile

index 1e1031deb8db12c2c04a03adb4b50d0fb7a4d041..dec7ec3c11b9190d2d04ba50c66a5ed5b8818f99 100644 (file)
@@ -55,6 +55,10 @@ HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.eglibc_installed
 HOST_BUILD_DIR1:=$(HOST_BUILD_DIR)-initial
 HOST_BUILD_DIR2:=$(HOST_BUILD_DIR)-final
 
+# XXX: {e,}glibc does not build w/ -Os
+# http://sourceware.org/bugzilla/show_bug.cgi?id=5203
+EGLIBC_CFLAGS:=$(subst -Os,-O2,$(TARGET_CFLAGS))
+
 EGLIBC_CONFIGURE:= \
        BUILD_CC="$(HOSTCC)" \
        $(TARGET_CONFIGURE_OPTS) \