add uclibc 0.9.30.1
authorFelix Fietkau <nbd@openwrt.org>
Mon, 23 Mar 2009 21:04:30 +0000 (21:04 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 23 Mar 2009 21:04:30 +0000 (21:04 +0000)
SVN-Revision: 15000

package/base-files/Makefile
toolchain/uClibc/Config.in
toolchain/uClibc/patches-0.9.30/130-sockets_throw.patch
toolchain/uClibc/patches-0.9.30/180-fix_kernel_types_with_recent_kernel.patch [deleted file]

index 33e8237819865e2debb467179e134509f06059ee..57d53ecc1fc1cd84576bab94d9c537a760342a1f 100644 (file)
@@ -30,6 +30,10 @@ else
   LIBGCC_VERSION:=<LIBGCC_VERSION>
 endif
 
+ifneq ($(LIBC_VERSION),0.9.28)
+  LIBC_VERSION:=$(LIBC_VERSION)$(LIBC_PATCHVER)
+endif
+
 CONFIG_PACKAGE_base-files$(TARGET):=$(CONFIG_PACKAGE_base-files)
 
 define Package/base-files$(TARGET)
index 9b670bd55adc414f277f7c714fde93aa058a61c9..78abd98c455d1243796e5d3734f900d03355713b 100644 (file)
@@ -28,6 +28,7 @@ config UCLIBC_EXTRA_VERSION
        depends on TOOLCHAINOPTS && USE_UCLIBC
        default "snapshot"   if UCLIBC_VERSION_SNAPSHOT
        default ".2"         if UCLIBC_VERSION_0_9_28
+       default ".1"         if UCLIBC_VERSION_0_9_30
        default ""
        help
            Default for version 0.9.28 is ".02", for daily snapshot it's just "snapshot"
index 4072804e4724d34fcabf0bd5d2eaee7f41be0486..619d01670ae29936fb590f0fb669d6e9ec047ffc 100644 (file)
@@ -1,12 +1,11 @@
-diff -urN uClibc-0.9.29/libc/sysdeps/linux/mips/bits/socket.h uClibc-0.9.29.new/libc/sysdeps/linux/mips/bits/socket.h
---- uClibc-0.9.29/libc/sysdeps/linux/mips/bits/socket.h        2006-12-06 22:46:56.000000000 +0100
-+++ uClibc-0.9.29.new/libc/sysdeps/linux/mips/bits/socket.h    2007-12-31 14:25:29.000000000 +0100
-@@ -269,7 +269,7 @@
+--- a/libc/sysdeps/linux/mips/bits/socket.h
++++ b/libc/sysdeps/linux/mips/bits/socket.h
+@@ -269,7 +269,7 @@ struct cmsghdr
  #define CMSG_LEN(len)   (CMSG_ALIGN (sizeof (struct cmsghdr)) + (len))
  
- extern struct cmsghdr * __NTH (__cmsg_nxthdr (struct msghdr *__mhdr,
--                                    struct cmsghdr *__cmsg)) __THROW;
-+                                    struct cmsghdr *__cmsg));
+ extern struct cmsghdr *__cmsg_nxthdr (struct msghdr *__mhdr,
+-                                    struct cmsghdr *__cmsg) __THROW;
++                                    struct cmsghdr *__cmsg);
  #ifdef __USE_EXTERN_INLINES
  # ifndef _EXTERN_INLINE
  #  define _EXTERN_INLINE extern __inline
diff --git a/toolchain/uClibc/patches-0.9.30/180-fix_kernel_types_with_recent_kernel.patch b/toolchain/uClibc/patches-0.9.30/180-fix_kernel_types_with_recent_kernel.patch
deleted file mode 100644 (file)
index 89c60fe..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-From df180f43dd9fc651ac760e7fe4a4dcf9e6dd42f1 Mon Sep 17 00:00:00 2001
-From: kraj <kraj@69ca8d6d-28ef-0310-b511-8ec308f3f277>
-Date: Tue, 23 Dec 2008 09:04:50 +0000
-Subject: [PATCH] These defines needs to be considered after recent linux kernel combined i386 and x86_64 into x86
-
-git-svn-id: svn+ssh://uclibc.org/svn/trunk/uClibc@24515 69ca8d6d-28ef-0310-b511-8ec308f3f277
----
- libc/sysdeps/linux/i386/bits/kernel_types.h |    8 ++++++--
- 1 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/libc/sysdeps/linux/i386/bits/kernel_types.h b/libc/sysdeps/linux/i386/bits/kernel_types.h
-index 6609dd3..8641a48 100644
---- a/libc/sysdeps/linux/i386/bits/kernel_types.h
-+++ b/libc/sysdeps/linux/i386/bits/kernel_types.h
-@@ -7,10 +7,14 @@
- /* a hack for compiling a 32 bit user space with 64 bit
-  * kernel on x86_64  */
--#if !defined(__ARCH_I386_POSIX_TYPES_H) && !defined(_ASM_X86_64_POSIX_TYPES_H)
-+#if !defined(__ARCH_I386_POSIX_TYPES_H) && \
-+    !defined(_ASM_X86_64_POSIX_TYPES_H) && \
-+    !defined(_ASM_X86_POSIX_TYPES_32_H) && \
-+    !defined(_ASM_X86_POSIX_TYPES_64_H)
- #define _ASM_X86_64_POSIX_TYPES_H
- #define __ARCH_I386_POSIX_TYPES_H
--
-+#define _ASM_X86_POSIX_TYPES_32_H
-+#define _ASM_X86_POSIX_TYPES_64_H
- typedef unsigned short        __kernel_dev_t;
- typedef unsigned long __kernel_ino_t;
- typedef unsigned short        __kernel_mode_t;
--- 
-1.5.6.5
-
-diff -ruN uClibc-0.9.30-old/libc/sysdeps/linux/x86_64/bits/kernel_types.h uClibc-0.9.30-new/libc/sysdeps/linux/x86_64/bits/kernel_types.h
---- uClibc-0.9.30-old/libc/sysdeps/linux/x86_64/bits/kernel_types.h    2008-07-23 13:23:36.000000000 +0200
-+++ uClibc-0.9.30-new/libc/sysdeps/linux/x86_64/bits/kernel_types.h    2009-01-21 16:33:27.000000000 +0100
-@@ -4,8 +4,10 @@
-  * our private content, and not the kernel header, will win.
-  *  -Erik
-  */
--#ifndef _ASM_X86_64_POSIX_TYPES_H
-+#if !defined(_ASM_X86_64_POSIX_TYPES_H) && \
-+    !defined(_ASM_X86_POSIX_TYPES_64_H)
- #define _ASM_X86_64_POSIX_TYPES_H
-+#define _ASM_X86_POSIX_TYPES_64_H
- typedef unsigned long __kernel_dev_t;
- typedef unsigned long __kernel_ino_t;