remove ipkg directory, add conffiles, normalize Makefile.
authorNicolas Thill <nico@openwrt.org>
Sun, 18 Jun 2006 18:10:41 +0000 (18:10 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 18 Jun 2006 18:10:41 +0000 (18:10 +0000)
SVN-Revision: 3994

openwrt/package/hostapd/Makefile
openwrt/package/hostapd/ipkg/hostapd-mini.conffiles [deleted file]
openwrt/package/hostapd/ipkg/hostapd.conffiles [deleted file]

index f4a6145213a94b7783082d25b0a9b8dfd62edabc..4a1c3f926500ed03f57eb7b922e691b3dfa08fd8 100644 (file)
@@ -16,6 +16,36 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(TOPDIR)/package/rules.mk
 
+define Package/hostapd
+SECTION:=net
+CATEGORY:=Network
+DEPENDS:=+libopenssl
+TITLE:=IEEE 802.1x Authenticator
+DESCRIPTION:=IEEE 802.1x/WPA/EAP/RADIUS Authenticator
+URL:=http://hostap.epitest.fi/
+endef
+
+define Package/hostapd/conffiles
+/etc/hostapd.conf
+endef
+
+define Package/hostapd-mini
+$(call Package/hostapd)
+TITLE:=IEEE 802.1x Authenticator (WPA-PSK only)
+DEPENDS:=
+DESCRIPTION:=IEEE 802.1x/WPA/EAP/RADIUS Authenticator (WPA-PSK only)
+endef
+
+define Package/hostapd-mini/conffiles
+/etc/hostapd.conf
+endef
+
+define Package/hostapd-utils
+$(call Package/hostapd)
+DEPENDS:=@PACKAGE_hostapd||PACKAGE_hostapd-mini
+TITLE:=IEEE 802.1x Authenticator (utils)
+DESCRIPTION:=IEEE 802.1x/WPA/EAP/RADIUS Authenticator (command line utils)
+endef
 
 define Build/ConfigureTarget
        $(CP) $(PKG_BUILD_DIR) $(PKG_BUILD_DIR)_$(1)
@@ -73,39 +103,14 @@ define Build/Clean
        rm -rf $(PKG_BUILD_DIR)_mini
 endef
 
-define Package/hostapd
-SECTION:=net
-CATEGORY:=Network
-DEPENDS:=+libopenssl
-TITLE:=IEEE 802.1x Authenticator
-DESCRIPTION:=IEEE 802.1x/WPA/EAP/RADIUS Authenticator
-URL:=http://hostap.epitest.fi/
-endef
-
-define Package/hostapd-mini
-$(call Package/hostapd)
-TITLE:=IEEE 802.1x Authenticator (WPA-PSK only)
-DEPENDS:=
-DESCRIPTION:=IEEE 802.1x/WPA/EAP/RADIUS Authenticator (WPA-PSK only)
-endef
-
-define Package/hostapd-utils
-$(call Package/hostapd)
-DEPENDS:=@PACKAGE_hostapd||PACKAGE_hostapd-mini
-TITLE:=IEEE 802.1x Authenticator (utils)
-DESCRIPTION:=IEEE 802.1x/WPA/EAP/RADIUS Authenticator (command line utils)
-endef
-
 define Package/hostapd-utils/install
        install -m0755 -d $(1)/usr/sbin
        install -m0755 $(PKG_BUILD_DIR)/hostapd_cli $(1)/usr/sbin/
 endef
 
-
 $(eval $(call Package/Template,hostapd,default))
 $(eval $(call Package/Template,hostapd-mini,mini))
 
 $(eval $(call BuildPackage,hostapd))
 $(eval $(call BuildPackage,hostapd-mini))
 $(eval $(call BuildPackage,hostapd-utils))
-
diff --git a/openwrt/package/hostapd/ipkg/hostapd-mini.conffiles b/openwrt/package/hostapd/ipkg/hostapd-mini.conffiles
deleted file mode 100644 (file)
index f619800..0000000
+++ /dev/null
@@ -1 +0,0 @@
-/etc/hostapd.conf
diff --git a/openwrt/package/hostapd/ipkg/hostapd.conffiles b/openwrt/package/hostapd/ipkg/hostapd.conffiles
deleted file mode 100644 (file)
index f619800..0000000
+++ /dev/null
@@ -1 +0,0 @@
-/etc/hostapd.conf