ar71xx: image: build initramfs images for more boards
authorGabor Juhos <juhosg@openwrt.org>
Tue, 27 Mar 2012 19:38:13 +0000 (19:38 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 27 Mar 2012 19:38:13 +0000 (19:38 +0000)
SVN-Revision: 31116

target/linux/ar71xx/image/Makefile

index da4d1fde5c2d3f3aa85f8f2606ffff1653cbcf91..46eac5e12d311874a8449e52d51392b3f1c738eb 100644 (file)
@@ -221,11 +221,19 @@ define Image/Build/Cameo913x
        $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo913x_mtdlayout),983040,2949120,$(4))
 endef
 
+define Image/Build/Cameo913x/initramfs
+       $(call MkuImageLzma/initramfs,$(2),$(3) $(cameo913x_mtdlayout))
+endef
+
 cameo7240_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,960k(kernel),2752k(rootfs),64k(mac)ro,64k(art)ro,3712k@0x40000(firmware)
 define Image/Build/Cameo7240
        $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo7240_mtdlayout),983040,2818048,$(4))
 endef
 
+define Image/Build/Cameo7240/initramfs
+       $(call MkuImageLzma/initramfs,$(2),$(3) $(cameo7240_mtdlayout))
+endef
+
 define Image/Build/Ath
        $(call Sysupgrade/$(7),$(1),$(2),$(5),$(6))
        if [ -e "$(call sysupname,$(1),$(2))" ]; then \
@@ -342,6 +350,10 @@ define Image/Build/ALFA
        fi
 endef
 
+define Image/Build/ALFA/initramfs
+       $(call MkuImageLzma/initramfs,$(2),$(3))
+endef
+
 define Image/Build/TPLINKOLD/loader
        $(call Image/BuildLoaderAlone,$(1),gz,$(2),0x22000,0)
 endef
@@ -568,6 +580,10 @@ define Image/Build/Zcomax
        fi
 endef
 
+define Image/Build/Zcomax/initramfs
+       $(call MkuImageLzma/initramfs,$(2),$(3))
+endef
+
 define Image/Build/Template/initramfs/initramfs
        $(call Image/Build/$(1)/initramfs,initramfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
 endef