add pciutils v2.2.1
authorImre Kaloz <kaloz@openwrt.org>
Tue, 31 Jan 2006 11:07:21 +0000 (11:07 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 31 Jan 2006 11:07:21 +0000 (11:07 +0000)
SVN-Revision: 3077

openwrt/package/Config.in
openwrt/package/pciutils/Config.in [new file with mode: 0644]
openwrt/package/pciutils/Makefile [new file with mode: 0644]
openwrt/package/pciutils/ipkg/pciutils.control [new file with mode: 0644]

index 54fc4b794d7f93c505a29e11a755afd049c5e63a..f10bca13bbf1d6d0ecd3b1cfa1d702f8033b0c22 100644 (file)
@@ -256,6 +256,7 @@ source "package/bc/Config.in"
 source "package/gdbserver/Config.in"
 source "package/pcmcia-cs/Config.in"  # pcmcia-utils
 source "package/usbutils/Config.in"  # lsusb
+source "package/pciutils/Config.in"
 source "package/strace/Config.in"
 source "package/udev/Config.in"
 source "package/watchdog/Config.in"
diff --git a/openwrt/package/pciutils/Config.in b/openwrt/package/pciutils/Config.in
new file mode 100644 (file)
index 0000000..e76962f
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PCIUTILS
+       prompt "pciutils.......................... Linux PCI Utilities"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         This package contains various utilities for inspecting and setting of
+         devices connected to the PCI bus.
diff --git a/openwrt/package/pciutils/Makefile b/openwrt/package/pciutils/Makefile
new file mode 100644 (file)
index 0000000..6318344
--- /dev/null
@@ -0,0 +1,35 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pciutils
+PKG_VERSION:=2.2.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=c18e2a5f04e9abae5a42439de294f086
+
+PKG_SOURCE_URL:=ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PCIUTILS,pciutils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" IDSDIR="/usr/share" HOST=$(GNU_TARGET_NAME)
+       touch $@
+
+$(IPKG_PCIUTILS):
+       install -d -m0755 $(IDIR_PCIUTILS)/usr/sbin
+       install -d -m0755 $(IDIR_PCIUTILS)/usr/share
+       cp -fpR $(PKG_BUILD_DIR)/{lspci,setpci} $(IDIR_PCIUTILS)/usr/sbin/
+       cp -fpR $(PKG_BUILD_DIR)/pci.ids $(IDIR_PCIUTILS)/usr/share/
+       $(RSTRIP) $(IDIR_PCIUTILS)/
+       $(IPKG_BUILD) $(IDIR_PCIUTILS) $(PACKAGE_DIR)
diff --git a/openwrt/package/pciutils/ipkg/pciutils.control b/openwrt/package/pciutils/ipkg/pciutils.control
new file mode 100644 (file)
index 0000000..b3f0c4e
--- /dev/null
@@ -0,0 +1,4 @@
+Package: pciutils
+Priority: optional
+Section: sys
+Description: Linux PCI Utilities