move alsa from target/linux/package to package, add compile fix for linux 2.4
authorFelix Fietkau <nbd@openwrt.org>
Wed, 31 May 2006 15:27:00 +0000 (15:27 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 31 May 2006 15:27:00 +0000 (15:27 +0000)
SVN-Revision: 3862

openwrt/package/alsa/Config.in [new file with mode: 0644]
openwrt/package/alsa/Makefile [new file with mode: 0644]
openwrt/package/alsa/files/alsa.modules [new file with mode: 0644]
openwrt/package/alsa/ipkg/kmod-alsa.control [new file with mode: 0644]
openwrt/package/alsa/patches/100-compile_fix.patch [new file with mode: 0644]
openwrt/target/linux/package/alsa/Config.in [deleted file]
openwrt/target/linux/package/alsa/Makefile [deleted file]
openwrt/target/linux/package/alsa/files/alsa.modules [deleted file]
openwrt/target/linux/package/alsa/ipkg/kmod-alsa.control [deleted file]

diff --git a/openwrt/package/alsa/Config.in b/openwrt/package/alsa/Config.in
new file mode 100644 (file)
index 0000000..55d9abd
--- /dev/null
@@ -0,0 +1,9 @@
+config PACKAGE_KMOD_ALSA
+       prompt "kmod-alsa......................... Alsa Sound Drivers"
+       tristate
+    depends LINUX_2_4_X86 || LINUX_2_4_BRCM || LINUX_2_6_X86 || LINUX_2_6_BRCM
+       depends PACKAGE_KMOD_USB_CONTROLLER
+       select PACKAGE_KMOD_SOUNDCORE
+       default m if DEVEL
+       help
+         Alsa Drivers for USB Soundcards
diff --git a/openwrt/package/alsa/Makefile b/openwrt/package/alsa/Makefile
new file mode 100644 (file)
index 0000000..5703db1
--- /dev/null
@@ -0,0 +1,70 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+include $(TOPDIR)/package/kernel.mk
+
+PKG_NAME:=alsa-driver
+PKG_VERSION:=1.0.11
+PKG_RELEASE:=1
+PKG_MD5SUM:=57534e4297cd683371402220e3753885
+
+PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+ifeq ($(LINUX_KARCH),i386)
+KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic -I$(LINUX_DIR)/include/asm-i386/mach-default
+KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
+endif
+ifeq ($(LINUX_KARCH),mips)
+KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
+KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
+endif
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); \
+               CFLAGS="$(KERNEL_C_INCS)" \
+               ./configure \
+               --with-build=$(LINUX_DIR) \
+               --with-kernel=$(LINUX_DIR) \
+               --with-cross=$(KERNEL_CROSS) \
+               --with-redhat=no \
+               --with-suse=no \
+               --with-oss=yes \
+               --with-isapnp=no \
+               --with-sequencer=no \
+               --with-cards=usb-audio \
+       );
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               ARCH="$(LINUX_KARCH)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               c_opts="$(KERNEL_C_OPTS)" \
+               all
+endef
+
+define Package/kmod-alsa
+ SECTION:=drivers
+ CATEGORY:=Drivers
+ DEPENDS:=@PCI_SUPPORT
+ TITLE:=Advanced Linux Sound Architecture
+ DESCRIPTION:=Advanced Linux Sound Architecture
+ URL:=http://alsa-project.org/
+ VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+endef
+
+define Package/kmod-alsa/install
+       install -d -m0755 $(1)/etc/modules.d
+       install -m0644 ./files/alsa.modules $(1)/etc/modules.d/70-alsa
+       install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
+       install -m0644 $(PKG_BUILD_DIR)/modules/*.$(LINUX_KMOD_SUFFIX) \
+               $(1)/lib/modules/$(LINUX_VERSION)/
+endef
+
+$(eval $(call BuildPackage,kmod-alsa))
diff --git a/openwrt/package/alsa/files/alsa.modules b/openwrt/package/alsa/files/alsa.modules
new file mode 100644 (file)
index 0000000..6b16c8c
--- /dev/null
@@ -0,0 +1,10 @@
+snd-page-alloc
+snd
+snd-timer
+snd-pcm
+snd-rawmidi
+snd-usb-lib
+snd-hwdep
+snd-usb-audio
+snd-mixer-oss
+snd-pcm-oss
diff --git a/openwrt/package/alsa/ipkg/kmod-alsa.control b/openwrt/package/alsa/ipkg/kmod-alsa.control
new file mode 100644 (file)
index 0000000..5641785
--- /dev/null
@@ -0,0 +1,5 @@
+Package: kmod-alsa
+Priority: optional
+Section: sys
+Depends: kmod-usb-audio
+Description: Alsa Drivers for USB Soundcards
diff --git a/openwrt/package/alsa/patches/100-compile_fix.patch b/openwrt/package/alsa/patches/100-compile_fix.patch
new file mode 100644 (file)
index 0000000..2e2a3df
--- /dev/null
@@ -0,0 +1,18 @@
+diff -urN alsa.old/include/adriver.h alsa.dev/include/adriver.h
+--- alsa.old/include/adriver.h 2006-04-19 08:24:30.000000000 +0200
++++ alsa.dev/include/adriver.h 2006-05-31 17:24:49.000000000 +0200
+@@ -451,7 +451,7 @@
+ #endif /* < 2.6.0 */
+ /* workarounds for USB API */
+-#if defined(SND_NEED_USB_WRAPPER) && (defined(CONFIG_USB) || defined(CONFIG_USB_MODULE))
++#if 1
+ #include <linux/usb.h>
+@@ -1174,4 +1174,5 @@
+  */
+ #define OPL3_HW_OPL3_PC98     0x0305  /* PC9800 */
++#undef info /* used in several structs */
+ #endif /* __SOUND_LOCAL_DRIVER_H */
diff --git a/openwrt/target/linux/package/alsa/Config.in b/openwrt/target/linux/package/alsa/Config.in
deleted file mode 100644 (file)
index 55d9abd..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-config PACKAGE_KMOD_ALSA
-       prompt "kmod-alsa......................... Alsa Sound Drivers"
-       tristate
-    depends LINUX_2_4_X86 || LINUX_2_4_BRCM || LINUX_2_6_X86 || LINUX_2_6_BRCM
-       depends PACKAGE_KMOD_USB_CONTROLLER
-       select PACKAGE_KMOD_SOUNDCORE
-       default m if DEVEL
-       help
-         Alsa Drivers for USB Soundcards
diff --git a/openwrt/target/linux/package/alsa/Makefile b/openwrt/target/linux/package/alsa/Makefile
deleted file mode 100644 (file)
index 665fc00..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-include ../../rules.mk
-
-PKG_NAME:=alsa-driver
-PKG_VERSION:=1.0.11rc4
-PKG_RELEASE:=1
-PKG_MD5SUM:=8e5794026082a964b09b46f9d881e6ec
-
-PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
-
-ifeq ($(LINUX_KARCH),i386)
-KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic -I$(LINUX_DIR)/include/asm-i386/mach-default
-KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
-endif
-ifeq ($(LINUX_KARCH),mips)
-KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
-KERNEL_C_OPTS:= -Os -G 0 -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
-endif
-
-$(eval $(call PKG_template,KMOD_ALSA,kmod-alsa,$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))))
-
-$(PKG_BUILD_DIR)/.configured:
-       (cd $(PKG_BUILD_DIR); \
-               CFLAGS="$(KERNEL_C_INCS)" \
-               ./configure \
-               --with-build=$(LINUX_DIR) \
-               --with-kernel=$(LINUX_DIR) \
-               --with-cross=$(KERNEL_CROSS) \
-               --with-redhat=no \
-               --with-suse=no \
-               --with-oss=yes \
-               --with-isapnp=no \
-               --with-sequencer=no \
-               --with-cards=usb-audio \
-       );
-       touch $@
-
-$(PKG_BUILD_DIR)/.built:
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               ARCH="$(LINUX_KARCH)" \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               c_opts="$(KERNEL_C_OPTS)" \
-               all
-       touch $@
-
-$(IPKG_KMOD_ALSA):
-       install -d -m0755 $(IDIR_KMOD_ALSA)/etc/modules.d
-       install -m0644 ./files/alsa.modules $(IDIR_KMOD_ALSA)/etc/modules.d/70-alsa
-       install -d -m0755 $(IDIR_KMOD_ALSA)/lib/modules/$(LINUX_VERSION)
-       install -m0644 $(PKG_BUILD_DIR)/modules/*.$(LINUX_KMOD_SUFFIX) \
-               $(IDIR_KMOD_ALSA)/lib/modules/$(LINUX_VERSION)/
-       $(IPKG_BUILD) $(IDIR_KMOD_ALSA) $(PACKAGE_DIR)
diff --git a/openwrt/target/linux/package/alsa/files/alsa.modules b/openwrt/target/linux/package/alsa/files/alsa.modules
deleted file mode 100644 (file)
index 6b16c8c..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-snd-page-alloc
-snd
-snd-timer
-snd-pcm
-snd-rawmidi
-snd-usb-lib
-snd-hwdep
-snd-usb-audio
-snd-mixer-oss
-snd-pcm-oss
diff --git a/openwrt/target/linux/package/alsa/ipkg/kmod-alsa.control b/openwrt/target/linux/package/alsa/ipkg/kmod-alsa.control
deleted file mode 100644 (file)
index 5641785..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-Package: kmod-alsa
-Priority: optional
-Section: sys
-Depends: kmod-usb-audio
-Description: Alsa Drivers for USB Soundcards