kernel: fix OHCI and EHCI modules for AT91
authorFlorian Fainelli <florian@openwrt.org>
Sat, 4 Jul 2015 01:24:37 +0000 (01:24 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 4 Jul 2015 01:24:37 +0000 (01:24 +0000)
We were not copying the additional files needed to get USB to work on
the AT91 platforms, make sure we do this.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 46172

package/kernel/linux/modules/usb.mk

index 446a92aca841f9853d6da6fb6969c1ddef0693a4..8f6013c3dbb986d83374f6d6f8935f89fdde6287 100644 (file)
@@ -315,7 +315,10 @@ define KernelPackage/usb-ohci
   FILES:= \
        $(LINUX_DIR)/drivers/usb/host/ohci-hcd.ko \
        $(LINUX_DIR)/drivers/usb/host/ohci-platform.ko
-  AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform,1)
+  ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ohci-at91.ko),)
+    FILES+=$(LINUX_DIR)/drivers/usb/host/ohci-at91.ko
+  endif
+  AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform ohci-at91,1)
   $(call AddDepends/usb)
 endef
 
@@ -416,14 +419,18 @@ define KernelPackage/usb2
        CONFIG_USB_EHCI_MXC=y \
        CONFIG_USB_OCTEON_EHCI=y \
        CONFIG_USB_EHCI_HCD_ORION=y \
-       CONFIG_USB_EHCI_HCD_PLATFORM=y
+       CONFIG_USB_EHCI_HCD_PLATFORM=y \
+       CONFIG_USB_EHCI_HCD_AT91=y
   FILES:= \
        $(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko \
        $(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
   ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
     FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-orion.ko
   endif
-  AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion,1)
+  ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko),)
+    FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko
+  endif
+  AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel,1)
   $(call AddDepends/usb)
 endef