target/linux/x86/image: add explicit prefix to grub-mkimage command
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 23 Nov 2016 08:27:55 +0000 (10:27 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 20 Dec 2016 15:24:21 +0000 (16:24 +0100)
In the latest version of grub-mkimage, the prefix option is mandatory.
Not supplying it fails with:
```
Prefix not specified (use the -p option).
```

In grub-2.02-beta2 a DEFAULT_DIRECTORY was defined
in `include/grub/osdep/hostfile_unix.h` as:
```
 #if defined (__NetBSD__)
 /* NetBSD uses /boot for its boot block.  */
 # define DEFAULT_DIRECTORY  "/"GRUB_DIR_NAME
 #else
 # define DEFAULT_DIRECTORY  "/"GRUB_BOOT_DIR_NAME"/"GRUB_DIR_NAME
 #endif
```

Where:
* GRUB_BOOT_DIR_NAME == boot
* GRUB_DIR_NAME == grub

This was used if the -p option was omitted.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
target/linux/x86/image/Makefile

index 99887cb32b723bb35cf6257c3543b0c06984be1c..965737ac631f3867c0d36963a86f7729ae25bd26 100644 (file)
@@ -68,6 +68,7 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        grub-mkimage \
+               -p /boot/grub \
                -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
                -o $(KDIR)/grub2/core.img \
                -O i386-pc \
@@ -106,6 +107,7 @@ define Image/Build/iso
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        grub-mkimage \
+               -p /boot/grub \
                -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
                -o $(KDIR)/grub2/eltorito.img \
                -O i386-pc \