update to 2.6.39.1
authorFlorian Fainelli <florian@openwrt.org>
Sat, 4 Jun 2011 18:26:54 +0000 (18:26 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 4 Jun 2011 18:26:54 +0000 (18:26 +0000)
SVN-Revision: 27110

target/linux/uml/Makefile
target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch [new file with mode: 0644]
target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch [new file with mode: 0644]
target/linux/uml/patches-2.6.39/006-uml_libc_link_errors.patch [new file with mode: 0644]
target/linux/uml/patches-2.6.39/901-lib_zlib_deflate_visible.patch [new file with mode: 0644]

index d22b57344827a949731dab0dc0fb32c719d7e0b6..92ad9848ce740fdd0f68c1756608a48043106d5d 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.38.6
+LINUX_VERSION:=2.6.39.1
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch
new file mode 100644 (file)
index 0000000..442c0ec
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
+ # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
+ # a lot more stack due to the lack of sharing of stacklots.  Also, gcc
+ # 4.3.0 needs -funit-at-a-time for extern inline functions.
+-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
+                       echo $(call cc-option,-fno-unit-at-a-time); \
+                       else echo $(call cc-option,-funit-at-a-time); fi ;)
diff --git a/target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch b/target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch
new file mode 100644 (file)
index 0000000..2be33d0
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
+                       echo $(call cc-option,-fno-unit-at-a-time); \
+                       else echo $(call cc-option,-funit-at-a-time); fi ;)
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
++
+ KBUILD_CFLAGS += $(cflags-y)
+--- a/arch/um/Makefile-x86_64
++++ b/arch/um/Makefile-x86_64
+@@ -24,3 +24,7 @@ LINK-y += -m64
+ # Do unit-at-a-time unconditionally on x86_64, following the host
+ KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
++
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
diff --git a/target/linux/uml/patches-2.6.39/006-uml_libc_link_errors.patch b/target/linux/uml/patches-2.6.39/006-uml_libc_link_errors.patch
new file mode 100644 (file)
index 0000000..0bab54c
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/arch/um/kernel/uml.lds.S
++++ b/arch/um/kernel/uml.lds.S
+@@ -35,6 +35,21 @@ SECTIONS
+     *(.gnu.warning)
+     *(.gnu.linkonce.t*)
+   }
++  /* Deal with multilib libc */
++  .rel.plt        :
++  {
++    *(.rel.plt)
++    PROVIDE_HIDDEN (__rel_iplt_start = .);
++    *(.rel.iplt)
++    PROVIDE_HIDDEN (__rel_iplt_end = .);
++  }
++  .rela.plt       :
++  {
++    *(.rela.plt)
++    PROVIDE_HIDDEN (__rela_iplt_start = .);
++    *(.rela.iplt)
++    PROVIDE_HIDDEN (__rela_iplt_end = .);
++  }
+   . = ALIGN(PAGE_SIZE);
+   .syscall_stub : {
diff --git a/target/linux/uml/patches-2.6.39/901-lib_zlib_deflate_visible.patch b/target/linux/uml/patches-2.6.39/901-lib_zlib_deflate_visible.patch
new file mode 100644 (file)
index 0000000..f4aba9b
--- /dev/null
@@ -0,0 +1,14 @@
+make ZLIB_DEFLATE visible, so that we can choose whether we want it built-in
+or as a module
+
+--- a/lib/Kconfig
++++ b/lib/Kconfig
+@@ -98,7 +98,7 @@ config ZLIB_INFLATE
+       tristate
+ config ZLIB_DEFLATE
+-      tristate
++      tristate "Zlib compression"
+ config LZO_COMPRESS
+       tristate