refresh kernel patches
authorGabor Juhos <juhosg@openwrt.org>
Thu, 23 Apr 2009 12:23:21 +0000 (12:23 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 23 Apr 2009 12:23:21 +0000 (12:23 +0000)
SVN-Revision: 15347

target/linux/ar71xx/patches-2.6.28/003-ar71xx_usb_host.patch
target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch

index 8392f48ef47d0e8be075c2ebedc64bbe6aa8b7c6..43bd4a152b2335edbda87679298d90bf686293e6 100644 (file)
@@ -28,7 +28,7 @@
        depends on USB_OHCI_HCD && (STB03xxx || PPC_MPC52xx)
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1034,6 +1034,11 @@ MODULE_LICENSE ("GPL");
+@@ -1036,6 +1036,11 @@ MODULE_LICENSE ("GPL");
  #define       PLATFORM_DRIVER         ixp4xx_ehci_driver
  #endif
  
index cf1abc96f5c6f5fac6a07e2dd826f703fee2690b..1170b0c839f8e09e17d3f558e93d2135103a4f01 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -77,6 +77,11 @@ config ADM6996_PHY
-       ---help---
-         Currently supports the ADM6996F switch
+@@ -80,6 +80,11 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+       tristate "Driver for Marvell 88E6060 switches"
  
 +config MICREL_PHY
 +      tristate "Drivers for Micrel/Kendin PHYs"
@@ -14,9 +14,9 @@
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY)   += broadcom.o
- obj-$(CONFIG_ICPLUS_PHY)      += icplus.o
+@@ -16,6 +16,7 @@ obj-$(CONFIG_ICPLUS_PHY)     += icplus.o
  obj-$(CONFIG_ADM6996_PHY)     += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
 +obj-$(CONFIG_MICREL_PHY)      += micrel.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o