mac80211: backport atomic64_t support for kernels that don't support it
authorFelix Fietkau <nbd@openwrt.org>
Sat, 9 Jul 2011 09:01:17 +0000 (09:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 9 Jul 2011 09:01:17 +0000 (09:01 +0000)
SVN-Revision: 27572

package/mac80211/patches/022-atomic64_backport.patch [new file with mode: 0644]

diff --git a/package/mac80211/patches/022-atomic64_backport.patch b/package/mac80211/patches/022-atomic64_backport.patch
new file mode 100644 (file)
index 0000000..27e2edb
--- /dev/null
@@ -0,0 +1,87 @@
+--- a/compat/Makefile
++++ b/compat/Makefile
+@@ -34,3 +34,8 @@ compat-$(CONFIG_COMPAT_KERNEL_2_6_39) +=
+       compat-2.6.39.o \
+       kstrtox.o
++ifndef CONFIG_64BIT
++ifndef CONFIG_GENERIC_ATOMIC64
++  compat-y += compat_atomic.o
++endif
++endif
+--- a/include/linux/compat-2.6.31.h
++++ b/include/linux/compat-2.6.31.h
+@@ -199,6 +199,20 @@ void compat_synchronize_threaded_irq(str
+ #define list_entry_rcu(ptr, type, member) \
+       container_of(rcu_dereference(ptr), type, member)
++#ifndef CONFIG_64BIT
++
++typedef struct {
++      long long counter;
++} atomic64_t;
++
++extern long long atomic64_read(const atomic64_t *v);
++extern long long atomic64_add_return(long long a, atomic64_t *v);
++
++#define atomic64_inc_return(v)          atomic64_add_return(1LL, (v))
++
++#endif
++
++
+ #endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,31)) */
+ #endif /* LINUX_26_31_COMPAT_H */
+--- /dev/null
++++ b/compat/compat_atomic.c
+@@ -0,0 +1,29 @@
++#include <linux/spinlock.h>
++#include <linux/module.h>
++
++static DEFINE_SPINLOCK(lock);
++
++long long atomic64_read(const atomic64_t *v)
++{
++    unsigned long flags;
++    long long val;
++
++    spin_lock_irqsave(&lock, flags);
++    val = v->counter;
++    spin_unlock_irqrestore(&lock, flags);
++    return val;
++}
++EXPORT_SYMBOL(atomic64_read);
++
++long long atomic64_add_return(long long a, atomic64_t *v)
++{
++    unsigned long flags;
++    long long val;
++
++    spin_lock_irqsave(&lock, flags);
++    val = v->counter += a;
++    spin_unlock_irqrestore(&lock, flags);
++    return val;
++}
++EXPORT_SYMBOL(atomic64_add_return);
++
+--- a/include/linux/compat-3.1.h
++++ b/include/linux/compat-3.1.h
+@@ -24,6 +24,18 @@
+ #define genl_dump_check_consistent(...) do {} while(0)
++/*
++ * In many versions, several architectures do not seem to include an
++ * atomic64_t implementation, and do not include the software emulation from
++ * asm-generic/atomic64_t.
++ * Detect and handle this here.
++ */
++#include <asm/atomic.h>
++
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31)) && !defined(ATOMIC64_INIT)
++#include <asm-generic/atomic64.h>
++#endif
++
+ #endif /* (LINUX_VERSION_CODE < KERNEL_VERSION(3,1,0)) */
+ #endif /* LINUX_3_1_COMPAT_H */