brcm63xx: Add support for Comtrend VR-3025u
authorJonas Gorski <jogo@openwrt.org>
Sun, 27 Jul 2014 17:44:45 +0000 (17:44 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 27 Jul 2014 17:44:45 +0000 (17:44 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: José Vázquez Fernández <ppvazquezfer@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 41847

target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
target/linux/brcm63xx/base-files/etc/uci-defaults/09_fix_crc
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.10/562-board_VR-3025u.patch [new file with mode: 0644]
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch [new file with mode: 0644]

index a04f4a50bdd5383bcd195490c411348ab9eafb45..1d42d472b5c16ee1940e77b50280cbc50bb7e2c0 100755 (executable)
@@ -81,6 +81,7 @@ DVG3810BN)
 96328A-1441N1 |\
 963281TAN |\
 963281T_TEF |\
+96368M-1541N |\
 96368MVNgr |\
 "F@ST2504n" |\
 "F@ST2704V2")
index 2f5e09b0b778c4aa3faee0cbb57135d0bf34eeec..7d9a6f79258e715e2eb5e36c6b5ac970789ab8cb 100755 (executable)
@@ -19,6 +19,7 @@ case "$board_name" in
        963281TAN |\
        963281T_TEF |\
        96358-502V |\
+       96368M-1541N |\
        96369R-1231N |\
        AW4339U |\
        "CPVA502+" |\
index fcd92812569dc85306251fd3adee9a5ae670c785..85d499e7857e4fdd6b33d43fc3883de3aefefb08 100755 (executable)
@@ -57,6 +57,11 @@ brcm63xx_detect() {
                brcm63xx_has_reset_button="true"
                ifname=eth0
                ;;
+       96368M-1541N)
+               brcm63xx_has_reset_button="true"
+               status_led="VR-3025u:green:power"
+               ifname="eth0"
+               ;;
        96369R-1231N)
                brcm63xx_has_reset_button="true"
                status_led="WAP-5813n:green:power"
index 11d7678581bcacca57b2c1f0939766c8ad142f2d..01235e4b26718c901c19372fb200ca0c269d0e98 100755 (executable)
@@ -230,6 +230,8 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96328A-1241N,6328,AR-5381u,,--pad 8)
        # Comtrend AR-5387un
        $(call Image/Build/CFE,$(1),96328A-1441N1,6328,AR-5387un,,--pad 8)
+       # Comtrend VR-3025u
+       $(call Image/Build/CFE,$(1),96368M-1541N,6368,VR-3025u,,--pad 16)
        # Comtrend WAP-5813n
        $(call Image/Build/CFE,$(1),96369R-1231N,6368,WAP-5813n,,--pad 4)
        # Davolink DV201AMR
diff --git a/target/linux/brcm63xx/patches-3.10/562-board_VR-3025u.patch b/target/linux/brcm63xx/patches-3.10/562-board_VR-3025u.patch
new file mode 100644 (file)
index 0000000..83b607f
--- /dev/null
@@ -0,0 +1,109 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -4450,6 +4450,98 @@ static struct board_info __initdata boar
+       .has_ehci0 = 1,
+ };
++static struct board_info __initdata board_VR3025u = {
++      .name                                   = "96368M-1541N",
++      .expected_cpu_id                = 0x6368,
++
++      .has_uart0                              = 1,
++      .has_pci                                = 1,
++      .has_ohci0                              = 1,
++      .has_ehci0                              = 1,
++
++      .has_enetsw                             = 1,
++      .enetsw = {
++              .used_ports = {
++                      [0] = {
++                              .used           = 1,
++                              .phy_id         = 1,
++                              .name           = "port1",
++                      },
++                      [1] = {
++                              .used           = 1,
++                              .phy_id         = 2,
++                              .name           = "port2",
++                      },
++                      [2] = {
++                              .used           = 1,
++                              .phy_id         = 3,
++                              .name           = "port3",
++                      },
++                      [3] = {
++                              .used           = 1,
++                              .phy_id         = 4,
++                              .name           = "port4",
++                      },
++              },
++      },
++
++      .leds = {
++              {
++                      .name           = "VR-3025u:green:dsl",
++                      .gpio           = 2,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025u:green:inet",
++                      .gpio           = 5,
++              },
++              {
++                      .name           = "VR-3025u:green:lan1",
++                      .gpio           = 6,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025u:green:lan2",
++                      .gpio           = 7,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025u:green:lan3",
++                      .gpio           = 8,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025u:green:lan4",
++                      .gpio           = 9,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025u:green:power",
++                      .gpio           = 22,
++                      .default_trigger = "default-on",
++              },
++              {
++                      .name           = "VR-3025u:red:power",
++                      .gpio           = 24,
++              },
++              {
++                      .name           = "VR-3025u:red:inet",
++                      .gpio           = 31,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc                   = "reset",
++                      .gpio                   = 34,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_RESTART,
++                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++                      .active_low             = 1,
++              },
++      },
++};
++
+ static struct b53_platform_data WAP5813n_b53_pdata = {
+       .alias = "eth0",
+ };
+@@ -4925,6 +5017,7 @@ static const struct board_info __initcon
+ #ifdef CONFIG_BCM63XX_CPU_6368
+       &board_96368mvwg,
+       &board_96368mvngr,
++      &board_VR3025u,
+       &board_WAP5813n,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_63268
diff --git a/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch b/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
new file mode 100644 (file)
index 0000000..07565d9
--- /dev/null
@@ -0,0 +1,109 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -4460,6 +4460,98 @@ static struct board_info __initdata boar
+       .has_ehci0 = 1,
+ };
++static struct board_info __initdata board_VR3025u = {
++      .name                                   = "96368M-1541N",
++      .expected_cpu_id                = 0x6368,
++
++      .has_uart0                              = 1,
++      .has_pci                                = 1,
++      .has_ohci0                              = 1,
++      .has_ehci0                              = 1,
++
++      .has_enetsw                             = 1,
++      .enetsw = {
++              .used_ports = {
++                      [0] = {
++                              .used           = 1,
++                              .phy_id         = 1,
++                              .name           = "port1",
++                      },
++                      [1] = {
++                              .used           = 1,
++                              .phy_id         = 2,
++                              .name           = "port2",
++                      },
++                      [2] = {
++                              .used           = 1,
++                              .phy_id         = 3,
++                              .name           = "port3",
++                      },
++                      [3] = {
++                              .used           = 1,
++                              .phy_id         = 4,
++                              .name           = "port4",
++                      },
++              },
++      },
++
++      .leds = {
++              {
++                      .name           = "VR-3025u:green:dsl",
++                      .gpio           = 2,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025u:green:inet",
++                      .gpio           = 5,
++              },
++              {
++                      .name           = "VR-3025u:green:lan1",
++                      .gpio           = 6,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025u:green:lan2",
++                      .gpio           = 7,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025u:green:lan3",
++                      .gpio           = 8,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025u:green:lan4",
++                      .gpio           = 9,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025u:green:power",
++                      .gpio           = 22,
++                      .default_trigger = "default-on",
++              },
++              {
++                      .name           = "VR-3025u:red:power",
++                      .gpio           = 24,
++              },
++              {
++                      .name           = "VR-3025u:red:inet",
++                      .gpio           = 31,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc                   = "reset",
++                      .gpio                   = 34,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_RESTART,
++                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++                      .active_low             = 1,
++              },
++      },
++};
++
+ static struct b53_platform_data WAP5813n_b53_pdata = {
+       .alias = "eth0",
+ };
+@@ -4935,6 +5027,7 @@ static const struct board_info __initcon
+ #ifdef CONFIG_BCM63XX_CPU_6368
+       &board_96368mvwg,
+       &board_96368mvngr,
++      &board_VR3025u,
+       &board_WAP5813n,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_63268