package:grub2: fix build error on linux missing libzfs
authorJohn Crispin <john@openwrt.org>
Fri, 1 Aug 2014 11:19:46 +0000 (11:19 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 1 Aug 2014 11:19:46 +0000 (11:19 +0000)
configure enables libzfs support on default.
This will break the build, on systems without libzfs.

Signed-off-by: Hans Ulli Kroll <ulli.kroll@googlemail.com>
SVN-Revision: 41935

package/boot/grub2/Makefile

index 83edfc614f2a9395e67eff7625c4d21ad79581d1..64a30589d0e7c036e98818c473cb1c940362003b 100644 (file)
@@ -48,12 +48,14 @@ CONFIGURE_ARGS += \
        --disable-werror \
        --disable-nls \
        --disable-device-mapper \
+       --disable-libzfs \
        --disable-grub-mkfont
 
 HOST_CONFIGURE_ARGS += \
        --target=$(REAL_GNU_TARGET_NAME) \
        --sbindir="$(STAGING_DIR_HOST)/bin" \
        --disable-werror \
+       --disable-libzfs \
        --disable-nls
 
 HOST_MAKE_FLAGS += \