gcc: always explicitly link against libstdc++, fixes build errors on some hosts that...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 12 Jan 2012 10:15:20 +0000 (10:15 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 12 Jan 2012 10:15:20 +0000 (10:15 +0000)
SVN-Revision: 29721

toolchain/gcc/common.mk

index 75ad8af6ffb1b66fae5b5b35e0cc21542e963de1..8b7453335070b1474cb7dbfedd37c5015efcbf53 100644 (file)
@@ -107,7 +107,7 @@ GCC_CONFIGURE:= \
                --disable-multilib \
                --disable-nls \
                $(GRAPHITE_CONFIGURE) \
-               $(if $(CONFIG_GCC_USE_GRAPHITE),--with-host-libstdcxx=-lstdc++) \
+               --with-host-libstdcxx=-lstdc++ \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \