ar7: fix kernel_entry extraction
authorGabor Juhos <juhosg@openwrt.org>
Sat, 5 May 2012 17:32:36 +0000 (17:32 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 5 May 2012 17:32:36 +0000 (17:32 +0000)
SVN-Revision: 31614

target/linux/ar7/image/Makefile

index 2d8ef6427185dfb009b4f580e96973dedab73c96..d27c2e888838dfed5c352f14743ee3df679d6ce3 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -75,9 +75,9 @@ endef
 #endef
 
 define Image/Build/EVA
-       $(STAGING_DIR_HOST)/bin/lzma2eva $(EVA_LOADADDR) 0x$${shell $(TARGET_CROSS)nm $(KDIR)/linux-*/vmlinux | grep kernel_entry | cut -d' ' -f1} $(KDIR)/vmlinux.lzma $(KDIR)/loader.eva 
+       $(STAGING_DIR_HOST)/bin/lzma2eva $(EVA_LOADADDR) 0x$${shell $(TARGET_CROSS)nm $(KDIR)/linux-*/vmlinux | grep -w kernel_entry | cut -d' ' -f1} $(KDIR)/vmlinux.lzma $(KDIR)/loader.eva
        dd if=$(KDIR)/loader.eva $(call align/$(1)) > $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
-       cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin 
+       cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
        $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin)
 endef