toolchain/glibc: fixup the libm.so linker script too
authorAndre Heider <a.heider@gmail.com>
Mon, 30 Jan 2023 09:55:53 +0000 (10:55 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 19 Feb 2023 18:44:39 +0000 (19:44 +0100)
Add it to the existing list to fix it up.

Found by mold:
toolchain-x86_64_gcc-12.2.0_glibc/lib/libm.so:4: GROUP ( /lib/libm.so.6  AS_NEEDED ( /lib/libmvec.so.1 ) )
                                                         ^ library not found: /lib/libm.so.6

Signed-off-by: Andre Heider <a.heider@gmail.com>
toolchain/glibc/Makefile

index 24526ceec2c92c3f1eb49543fd82978706897d52..bfb5598274c2a116bbaa5988b4c745ca41b86867 100644 (file)
@@ -20,7 +20,7 @@ define Host/Install
                install
        ( cd $(TOOLCHAIN_DIR) ; \
                for d in lib usr/lib ; do \
-                 for f in libc.so libpthread.so libgcc_s.so ; do \
+                 for f in libc.so libm.so libpthread.so libgcc_s.so ; do \
                    if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
                      $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
                    fi \