ltq-adsl-app: use ubus to provide metrics
authorAndre Heider <a.heider@gmail.com>
Tue, 26 Jan 2021 08:00:51 +0000 (09:00 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 8 Feb 2021 20:43:00 +0000 (21:43 +0100)
luci now uses ubus directly, so remove 'lucistat'.
For manual usage just print the ubus output, use luci for a pretty
version.

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/network/config/ltq-adsl-app/Makefile
package/network/config/ltq-adsl-app/files/dsl_control

index 0e8bacdbec87043148cd0a56c4c4d45738dff313..2e4792266c19d91977b740d232ba5ef4636e0f0d 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=dsl_cpe_control_danube
 PKG_VERSION:=3.24.4.4
-PKG_RELEASE:=9
+PKG_RELEASE:=10
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/dsl_cpe_control-$(PKG_VERSION)
 PKG_SOURCE_URL:=@OPENWRT
index 49c342d9d5094b0a8376fab54360cfc4f11dae63..4bd6e860e87f1e0845c80ed4bc4204fe3d3c0f42 100644 (file)
@@ -4,10 +4,11 @@
 START=97
 USE_PROCD=1
 
-extra_command "dslstat" "Get DSL status information"
-extra_command "lucistat" "Get status information in lua friendly format"
+dslstat() {
+       ubus call dsl metrics
+}
 
-. /lib/functions/lantiq_dsl.sh
+extra_command "dslstat" "Get DSL status information"
 
 annex_b=10_00_10_00_00_04_00_00
 annex_bdmt=10_00_00_00_00_00_00_00