toolchain/binutils: get rid of outdated libiberty hack
authorAndre Heider <a.heider@gmail.com>
Wed, 8 Feb 2023 17:58:05 +0000 (18:58 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 19 Feb 2023 18:44:39 +0000 (19:44 +0100)
This reverts commit 68fcb15f90edd92ef36990c5696b9e79df07a6ec.

binutils syncs libiberty from gcc, which defaults to not installing itself
since [0], see also [1].

That change is apparently part of binutils 2.24, and the oldest supported
version here is 2.37, hence we can remove this hack.

[0] https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=48d7db63ff581b026e057badf39f1f23fdf47928
[1] https://gcc.gnu.org/onlinedocs/libiberty/Using.html

Signed-off-by: Andre Heider <a.heider@gmail.com>
toolchain/binutils/Makefile

index 0b7558e3584afb89b5b73e684910ab9a37a528e5..ef3123aeb616ae4ab1e6b7231fd926043db13cf6 100644 (file)
@@ -100,7 +100,6 @@ define Host/Install
                prefix=$(TOOLCHAIN_DIR) \
                install
        $(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
-       $(RM) $(TOOLCHAIN_DIR)/initial/lib/libiberty.a
        $(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(HOST_BUILD_PREFIX)/bin/readelf
 endef