package/network: add PKGARCH:=all to non-binary packages
[openwrt/staging/jogo.git] / package / network / config / gre / Makefile
index 90f92d4da713f70a86e60c2be8d140c241565cf3..e3a79e11e4a4d81b2096a91c381cd6f819163ad1 100644 (file)
@@ -9,46 +9,28 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gre
 PKG_VERSION:=1
-PKG_RELEASE:=6
+PKG_RELEASE:=11
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gre/Default
-  SECTION:=net
-  CATEGORY:=Network
-  MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
 endef
 
 define Package/gre
-$(call Package/gre/Default)
+  SECTION:=net
+  CATEGORY:=Network
+  MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
   TITLE:=Generic Routing Encapsulation config support
+  DEPENDS:=+kmod-gre +IPV6:kmod-gre6 +resolveip
+  PROVIDES:=grev4 grev6
+  PKGARCH:=all
 endef
 
 define Package/gre/description
  Generic Routing Encapsulation config support (IPv4 and IPv6) in /etc/config/network.
 endef
 
-define Package/grev4
-$(call Package/gre/Default)
-  TITLE:=Generic Routing Encapsulation (IPv4) config support
-  DEPENDS:=@(PACKAGE_gre) +kmod-gre +resolveip
-endef
-
-define Package/grev4/description
- Generic Routing Encapsulation config support (IPv4) in /etc/config/network.
-endef
-
-define Package/grev6
-$(call Package/gre/Default)
-  TITLE:=Generic Routing Encapsulation (IPv6) config support
-  DEPENDS:=@(PACKAGE_gre) @IPV6 +kmod-gre6 +resolveip
-endef
-
-define Package/grev6/description
- Generic Routing Encapsulation config support (IPv6) in /etc/config/network.
-endef
-
 define Build/Compile
 endef
 
@@ -60,14 +42,4 @@ define Package/gre/install
        $(INSTALL_BIN) ./files/gre.sh $(1)/lib/netifd/proto/gre.sh
 endef
 
-define Package/grev4/install
-       :
-endef
-
-define Package/grev6/install
-       :
-endef
-
 $(eval $(call BuildPackage,gre))
-$(eval $(call BuildPackage,grev4))
-$(eval $(call BuildPackage,grev6))