don't force the install->compile, compile->prepare dependencies in subdir.mk
authorFelix Fietkau <nbd@openwrt.org>
Sat, 28 Jul 2007 02:53:54 +0000 (02:53 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 28 Jul 2007 02:53:54 +0000 (02:53 +0000)
SVN-Revision: 8202

include/subdir.mk
tools/Makefile

index 81a6f2a428bac257bd0f87a156bb66f533b83ac5..fe46ed0de04c26d2d1f197139cde3ba3bb000dc9 100644 (file)
@@ -23,8 +23,6 @@ $(call warn,$(1),$(2),$(3)    $(4))
 $(4)
 endef
 
-dep/compile=$(1)/prepare
-dep/install=$(1)/compile
 SUBTARGETS:=clean download prepare compile install update refresh prereq
 
 # Parameters: <subdir>
@@ -33,7 +31,7 @@ define subdir
   $(foreach bd,$($(1)/builddirs),
     $(call warn,$(1),d,BD $(1)/$(bd))
     $(foreach target,$(SUBTARGETS),
-      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $(call dep/$(target),$(1)/$(bd)) $($(1)/$(bd)/$(target)) $($(1)//$(target)))
+      $(call warn_eval,$(1)/$(bd),t,T,$(1)/$(bd)/$(target): $($(1)/$(bd)/$(target)) $(call $(1)//$(target),$(1)/$(bd)))
                @$$(MAKE) -j1 -C $(1)/$(bd) $(target)
 
       # legacy targets
index 0d6b51597732d3a81d9688c2c702fb614a85a67c..49b30be44b01c0e8c5c7d1050ef52b613132ea09 100644 (file)
@@ -23,6 +23,9 @@ $(STAGING_DIR)/include-host/.done:
 
 # prerequisites for the individual targets
 $(curdir)/ := .config
-$(curdir)//prepare := $(STAGING_DIR)/include-host/.done
+$(curdir)//prepare = $(STAGING_DIR)/include-host/.done
+$(curdir)//compile = $(1)/prepare
+$(curdir)//install = $(1)/compile
+
 $(eval $(call stampfile,$(curdir),tools))
 $(eval $(call subdir,$(curdir)))