package the TI TMP421 driver
authorImre Kaloz <kaloz@openwrt.org>
Tue, 17 Jun 2014 15:03:05 +0000 (15:03 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 17 Jun 2014 15:03:05 +0000 (15:03 +0000)
SVN-Revision: 41231

package/kernel/linux/modules/hwmon.mk

index 9dd47344de89c2748ba6f988d949ea96ac17a375..7831f701a2fcc97be34a6cb15722fff6f79ab562 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -258,3 +258,17 @@ define KernelPacakge/hwmon-gsc/description
 endef
 
 $(eval $(call KernelPackage,hwmon-gsc))
+
+define KernelPackage/hwmon-tmp421
+  TITLE:=TI TMP421 and compatible monitoring support
+  KCONFIG:=CONFIG_SENSORS_TMP421
+  FILES:=$(LINUX_DIR)/drivers/hwmon/tmp421.ko
+  AUTOLOAD:=$(call AutoLoad,60,tmp421)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPacakge/hwmon-tmp421/description
+  Kernel module for the Texas Instruments TMP421 and compatible chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-tmp421))