comgt: perform case insensitive match when probing for Huawei devices (#12039)
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 22 Sep 2012 14:55:17 +0000 (14:55 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 22 Sep 2012 14:55:17 +0000 (14:55 +0000)
SVN-Revision: 33507

package/comgt/Makefile
package/comgt/files/3g.sh

index ae8aa668baa2155e5ee7ce3f17a81e828ed45b90..6cb802c6003369286706aabf0380145dc9a5c2ae 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=20
+PKG_RELEASE:=21
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
index 9e44d0665055a6da2481e36dd94da5093611508a..2ed74b4c0845d90ef4cbcd2366064ae35357b7d7 100644 (file)
@@ -52,7 +52,7 @@ proto_3g_setup() {
                                export MODE="AT_OPSYS=${CODE}"
                        elif echo "$cardinfo" | grep -q "Sierra Wireless"; then
                                SIERRA=1
-                       elif echo "$cardinfo" | grep -q huawei; then
+                       elif echo "$cardinfo" | grep -qi huawei; then
                                case "$service" in
                                        umts_only) CODE="14,2";;
                                        gprs_only) CODE="13,1";;