BusyBox: Netcat 1.10 compatibility require server option
authorJohn Crispin <john@openwrt.org>
Fri, 13 Mar 2015 08:38:56 +0000 (08:38 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 13 Mar 2015 08:38:56 +0000 (08:38 +0000)
Netcat 1.10 compatibility require server options

1.10 compatibility without server option
produce error "NO OPT l!" and completely not function

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
SVN-Revision: 44746

package/utils/busybox/Makefile
package/utils/busybox/config/networking/Config.in

index fcfdc8bbefe0e563c85f0fa60e7ca34de94b5a92..7421c0a5e7d56cf16e91fb8429026c8525b65335 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2014 OpenWrt.org
+#
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.22.1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 80dd42abd0555645b10fa4485b41b38c81e1ed3e..52e38a3f0020701767f71e814c7d5f177ed18a2e 100644 (file)
@@ -67,6 +67,7 @@ config BUSYBOX_CONFIG_NC_110_COMPAT
        bool "Netcat 1.10 compatibility (+2.5k)"
        default BUSYBOX_DEFAULT_NC_110_COMPAT  # off specially for Rob
        depends on BUSYBOX_CONFIG_NC
+       select BUSYBOX_CONFIG_NC_SERVER
        help
          This option makes nc closely follow original nc-1.10.
          The code is about 2.5k bigger. It enables