ar71xx: ap83: define mtd layout via command line
authorGabor Juhos <juhosg@openwrt.org>
Thu, 23 Jan 2014 16:47:42 +0000 (16:47 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 23 Jan 2014 16:47:42 +0000 (16:47 +0000)
Also use the RKuImage macro becasue the original
firmware starts with the rootfs.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 39379

target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.10/615-MIPS-ath79-ap83-remove-mtd-partitions.patch [new file with mode: 0644]

index 801fb4cf434a91212ae175d3721fc8e902951382..2a003a82b3c80431c5b3b5d8da8d7e79e823bedb 100644 (file)
@@ -193,6 +193,7 @@ alfa_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,15936k(firmw
 all0258n_mtdlayout=mtdparts=spi0.0:256k(u-boot),64k(u-boot-env),6272k(firmware),1536k(failsafe),64k(art)
 all0315n_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,256k(u-boot-env),13568k(firmware),2048k(failsafe),256k(art)ro
 ap81_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,5120k(rootfs),2688k(kernel),64k(art)ro,7808k@0x50000(firmware)
+ap83_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,128k(u-boot-env)ro,4096k(rootfs),3648k(kernel),64k(art)ro,7744k@0x60000(firmware)
 ap96_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,6144k(rootfs),1728k(kernel),64k(art)ro,7872k@0x40000(firmware)
 ap113_mtd_layout=mtdparts=spi0.0:64k(u-boot),3008k(rootfs),896k(uImage),64k(NVRAM),64k(ART),3904k@0x10000(firmware)
 ap121_mtdlayout_2M=mtdparts=spi0.0:64k(u-boot)ro,1216k(rootfs),704k(kernel),64k(art)ro,1920k@0x10000(firmware)
@@ -878,7 +879,7 @@ $(eval $(call SingleProfile,ALFA,64k,ALFANX,alfa-nx,ALFA-NX,ttyS0,115200,$$(alfa
 $(eval $(call SingleProfile,ALFA,64k,HORNETUB,hornet-ub,HORNET-UB,ttyATH0,115200,$$(alfa_mtdlayout_8M),1638400,6291456,kernel_image,rootfs_image))
 
 $(eval $(call SingleProfile,AthGzip,64k,AP81,ap81,AP81,ttyS0,115200,$$(ap81_mtdlayout),2752512,5242880,RKuImage))
-$(eval $(call SingleProfile,AthGzip,64k,AP83,ap83,AP83,ttyS0,115200,,1310720,6619136,KRuImage))
+$(eval $(call SingleProfile,AthGzip,64k,AP83,ap83,AP83,ttyS0,115200,$$(ap83_mtdlayout),3735552,4194304,RKuImage))
 $(eval $(call SingleProfile,AthGzip,64k,AP96,ap96,AP96,ttyS0,115200,$$(ap96_mtdlayout),1769472,6291456,RKuImage))
 
 $(eval $(call SingleProfile,AthLzma,64k,ALFAAP96,alfa-ap96,ALFA-AP96,ttyS0,115200,$$(alfa_ap96_mtdlayout),2097152,13631488,RKuImage))
diff --git a/target/linux/ar71xx/patches-3.10/615-MIPS-ath79-ap83-remove-mtd-partitions.patch b/target/linux/ar71xx/patches-3.10/615-MIPS-ath79-ap83-remove-mtd-partitions.patch
new file mode 100644 (file)
index 0000000..60872ae
--- /dev/null
@@ -0,0 +1,44 @@
+--- a/arch/mips/ath79/mach-ap83.c
++++ b/arch/mips/ath79/mach-ap83.c
+@@ -42,41 +42,8 @@
+ #define AP83_KEYS_POLL_INTERVAL               20      /* msecs */
+ #define AP83_KEYS_DEBOUNCE_INTERVAL   (3 * AP83_KEYS_POLL_INTERVAL)
+-static struct mtd_partition ap83_flash_partitions[] = {
+-      {
+-              .name           = "u-boot",
+-              .offset         = 0,
+-              .size           = 0x040000,
+-              .mask_flags     = MTD_WRITEABLE,
+-      }, {
+-              .name           = "u-boot-env",
+-              .offset         = 0x040000,
+-              .size           = 0x020000,
+-              .mask_flags     = MTD_WRITEABLE,
+-      }, {
+-              .name           = "kernel",
+-              .offset         = 0x060000,
+-              .size           = 0x140000,
+-      }, {
+-              .name           = "rootfs",
+-              .offset         = 0x1a0000,
+-              .size           = 0x650000,
+-      }, {
+-              .name           = "art",
+-              .offset         = 0x7f0000,
+-              .size           = 0x010000,
+-              .mask_flags     = MTD_WRITEABLE,
+-      }, {
+-              .name           = "firmware",
+-              .offset         = 0x060000,
+-              .size           = 0x790000,
+-      }
+-};
+-
+ static struct physmap_flash_data ap83_flash_data = {
+       .width          = 2,
+-      .parts          = ap83_flash_partitions,
+-      .nr_parts       = ARRAY_SIZE(ap83_flash_partitions),
+ };
+ static struct resource ap83_flash_resources[] = {