ar71xx: refresh 2.6.33 patches
authorGabor Juhos <juhosg@openwrt.org>
Wed, 3 Mar 2010 09:40:17 +0000 (09:40 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 3 Mar 2010 09:40:17 +0000 (09:40 +0000)
SVN-Revision: 19960

19 files changed:
target/linux/ar71xx/patches-2.6.33/001-ar71xx_core.patch
target/linux/ar71xx/patches-2.6.33/003-ar71xx_usb_host.patch
target/linux/ar71xx/patches-2.6.33/005-ar71xx_mac_driver.patch
target/linux/ar71xx/patches-2.6.33/006-ar71xx_wdt_driver.patch
target/linux/ar71xx/patches-2.6.33/007-ar91xx_flash_driver.patch
target/linux/ar71xx/patches-2.6.33/102-mtd_m25p80_add_myloader_parser.patch
target/linux/ar71xx/patches-2.6.33/104-mtd_m25p80_add_redboot_parser.patch
target/linux/ar71xx/patches-2.6.33/108-mtd_fix_cfi_cmdset_0002_status_check.patch
target/linux/ar71xx/patches-2.6.33/109-mtd-wrt160nl-trx-parser.patch
target/linux/ar71xx/patches-2.6.33/110-usb-ehci-add-war-for-synopsys-hc-bug.patch
target/linux/ar71xx/patches-2.6.33/111-mtd-cfi_cmdset_0002-force-word-write.patch
target/linux/ar71xx/patches-2.6.33/200-rb4xx_nand_driver.patch
target/linux/ar71xx/patches-2.6.33/202-spi_vsc7385_driver.patch
target/linux/ar71xx/patches-2.6.33/203-pb44_spi_controller.patch
target/linux/ar71xx/patches-2.6.33/205-wndr3700-usb-led-driver.patch
target/linux/ar71xx/patches-2.6.33/206-nxp-74hc153-gpio-chip-driver.patch
target/linux/ar71xx/patches-2.6.33/300-mips_fw_myloader.patch
target/linux/ar71xx/patches-2.6.33/901-get_c0_compare_irq_function.patch
target/linux/ar71xx/patches-2.6.33/902-mips_clocksource_init_war.patch

index 95811694d4ed18e614023dbe9965f0fc1da8cf07..5b322d68f7250394b155ee93d92db654daf5d6e3 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.33/arch/mips/Makefile
-===================================================================
---- linux-2.6.33.orig/arch/mips/Makefile       2010-02-28 16:43:15.000000000 +0100
-+++ linux-2.6.33/arch/mips/Makefile    2010-02-28 16:45:56.397211344 +0100
-@@ -637,6 +637,13 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -637,6 +637,13 @@ else
  load-$(CONFIG_CPU_CAVIUM_OCTEON)      += 0xffffffff81100000
  endif
  
@@ -16,11 +14,9 @@ Index: linux-2.6.33/arch/mips/Makefile
  # temporary until string.h is fixed
  cflags-y += -ffreestanding
  
-Index: linux-2.6.33/arch/mips/Kconfig
-===================================================================
---- linux-2.6.33.orig/arch/mips/Kconfig        2010-02-28 16:43:15.000000000 +0100
-+++ linux-2.6.33/arch/mips/Kconfig     2010-02-28 16:46:56.150331076 +0100
-@@ -48,6 +48,23 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -48,6 +48,23 @@ config AR7
          Support for the Texas Instruments AR7 System-on-a-Chip
          family: TNETD7100, 7200 and 7300.
  
@@ -44,7 +40,7 @@ Index: linux-2.6.33/arch/mips/Kconfig
  config BCM47XX
        bool "BCM47XX based boards"
        select CEVT_R4K
-@@ -682,6 +699,7 @@
+@@ -682,6 +699,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
  endchoice
  
  source "arch/mips/alchemy/Kconfig"
index 0a428c78fe7360f4fd799cc0ec92b0605d4e80c2..238a79c9b9df1b26fcd3a00975454318dd0458bb 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/usb/host/Kconfig
 +++ b/drivers/usb/host/Kconfig
-@@ -98,6 +98,13 @@ config USB_EHCI_BIG_ENDIAN_DESC
-       depends on USB_EHCI_HCD && (440EPX || ARCH_IXP4XX)
-       default y
+@@ -109,6 +109,13 @@ config XPS_USB_HCD_XILINX
+               support both high speed and full speed devices, or high speed
+               devices only.
  
 +config USB_EHCI_AR71XX
 +      bool "USB EHCI support for AR71xx"
@@ -14,7 +14,7 @@
  config USB_EHCI_FSL
        bool "Support for Freescale on-chip EHCI USB controller"
        depends on USB_EHCI_HCD && FSL_SOC
-@@ -189,6 +196,13 @@ config USB_OHCI_HCD
+@@ -207,6 +214,13 @@ config USB_OHCI_HCD
          To compile this driver as a module, choose M here: the
          module will be called ohci-hcd.
  
@@ -30,7 +30,7 @@
        depends on USB_OHCI_HCD && (STB03xxx || PPC_MPC52xx)
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1141,6 +1141,11 @@ MODULE_LICENSE ("GPL");
+@@ -1158,6 +1158,11 @@ MODULE_LICENSE ("GPL");
  #define       PLATFORM_DRIVER         ehci_atmel_driver
  #endif
  
index 72fc978e81db07626da4405a2af70a46f14ab2fc..3721a9b866ac9affa983ef45f37de5c7e0a8080d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/Kconfig
 +++ b/drivers/net/Kconfig
-@@ -2126,6 +2126,8 @@ config ACENIC_OMIT_TIGON_I
+@@ -2128,6 +2128,8 @@ config ACENIC_OMIT_TIGON_I
  
          The safe and default value for this is N.
  
index bd6364ddb3cdaa3b4ef2a5a8ce1a2e565f36e5fc..d71a11b86aef4b952b5e9beb2ffcd9544bf222cc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/watchdog/Kconfig
 +++ b/drivers/watchdog/Kconfig
-@@ -850,6 +850,13 @@ config TXX9_WDT
+@@ -840,6 +840,13 @@ config TXX9_WDT
        help
          Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
  
@@ -16,7 +16,7 @@
  # POWERPC Architecture
 --- a/drivers/watchdog/Makefile
 +++ b/drivers/watchdog/Makefile
-@@ -113,6 +113,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
+@@ -112,6 +112,7 @@ obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt
  obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
  obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
  obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
index 244d820da5be62780ebf774f311265adf7c64944..127db55b61ce473022645c5eaf7934bbdae205d3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/maps/Kconfig
 +++ b/drivers/mtd/maps/Kconfig
-@@ -259,6 +259,13 @@ config MTD_ALCHEMY
+@@ -257,6 +257,13 @@ config MTD_ALCHEMY
        help
          Flash memory access on AMD Alchemy Pb/Db/RDK Reference Boards
  
index 320c76a0cc4dbd43111956fef60b8f9acf7380b8..45f743e06f2ec5b7413a2172dbd510333fc2a2a6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -867,6 +867,16 @@ static int __devinit m25p_probe(struct s
+@@ -922,6 +922,16 @@ static int __devinit m25p_probe(struct s
                                        part_probes, &parts, 0);
                }
  
index dbcdde088fc23591ad7b232a6d4995d3b94a5a96..43fe987df655dfc1688d5a9ba827b49a4825f1dd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -877,6 +877,15 @@ static int __devinit m25p_probe(struct s
+@@ -932,6 +932,15 @@ static int __devinit m25p_probe(struct s
                }
  #endif
  
index d4272ab1b3ed78580419e7ec3d682ee710533118..e0676cae936573a6fe8f1b4a875a85b207ec32e1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1141,8 +1141,8 @@ static int __xipram do_write_oneword(str
+@@ -1130,8 +1130,8 @@ static int __xipram do_write_oneword(str
                        break;
                }
  
@@ -11,7 +11,7 @@
  
                /* Latency issues. Drop the lock, wait a while and retry */
                UDELAY(map, chip, adr, 1);
-@@ -1158,6 +1158,8 @@ static int __xipram do_write_oneword(str
+@@ -1147,6 +1147,8 @@ static int __xipram do_write_oneword(str
  
                ret = -EIO;
        }
@@ -20,7 +20,7 @@
        xip_enable(map, chip, adr);
   op_done:
        chip->state = FL_READY;
-@@ -1504,7 +1506,6 @@ static int cfi_amdstd_write_buffers(stru
+@@ -1493,7 +1495,6 @@ static int cfi_amdstd_write_buffers(stru
        return 0;
  }
  
@@ -28,7 +28,7 @@
  /*
   * Handle devices with one erase region, that only implement
   * the chip erase command.
-@@ -1568,8 +1569,8 @@ static int __xipram do_erase_chip(struct
+@@ -1557,8 +1558,8 @@ static int __xipram do_erase_chip(struct
                        chip->erase_suspended = 0;
                }
  
@@ -39,7 +39,7 @@
  
                if (time_after(jiffies, timeo)) {
                        printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -1589,6 +1590,7 @@ static int __xipram do_erase_chip(struct
+@@ -1578,6 +1579,7 @@ static int __xipram do_erase_chip(struct
                ret = -EIO;
        }
  
@@ -47,7 +47,7 @@
        chip->state = FL_READY;
        xip_enable(map, chip, adr);
        put_chip(map, chip, adr);
-@@ -1656,9 +1658,9 @@ static int __xipram do_erase_oneblock(st
+@@ -1645,9 +1647,9 @@ static int __xipram do_erase_oneblock(st
                        chip->erase_suspended = 0;
                }
  
@@ -59,7 +59,7 @@
                }
  
                if (time_after(jiffies, timeo)) {
-@@ -1680,6 +1682,7 @@ static int __xipram do_erase_oneblock(st
+@@ -1669,6 +1671,7 @@ static int __xipram do_erase_oneblock(st
                ret = -EIO;
        }
  
index 7af88432a07d7f23841d5a02ae682f8e8bf64f57..037795b337695b8762d92a01599dfd4712440cb3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -886,6 +886,16 @@ static int __devinit m25p_probe(struct s
+@@ -941,6 +941,16 @@ static int __devinit m25p_probe(struct s
                                        part_probes, &parts, 0);
                }
  #endif
index 18994d08390e23cf37a51c7eeda4fea2caa988ae..076c39ea2b0298ce65c2cd25d8eb074b29c39342 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/host/ehci-q.c
 +++ b/drivers/usb/host/ehci-q.c
-@@ -1172,6 +1172,9 @@ static void end_unlink_async (struct ehc
+@@ -1194,6 +1194,9 @@ static void end_unlink_async (struct ehc
                ehci->reclaim = NULL;
                start_unlink_async (ehci, next);
        }
index 4be025d870135937013a16af4ce872384ddeeb3b..3215a7d9d3931dba8b4419e93ead9496fe804c6e 100644 (file)
@@ -35,7 +35,7 @@
  
  /* Atmel chips don't use the same PRI format as AMD chips */
  static void fixup_convert_atmel_pri(struct mtd_info *mtd, void *param)
-@@ -1315,6 +1319,7 @@ static int cfi_amdstd_write_words(struct
+@@ -1304,6 +1308,7 @@ static int cfi_amdstd_write_words(struct
  /*
   * FIXME: interleaved mode not tested, and probably not supported!
   */
@@ -43,7 +43,7 @@
  static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
                                    unsigned long adr, const u_char *buf,
                                    int len)
-@@ -1426,7 +1431,6 @@ static int __xipram do_write_buffer(stru
+@@ -1415,7 +1420,6 @@ static int __xipram do_write_buffer(stru
        return ret;
  }
  
@@ -51,7 +51,7 @@
  static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
                                    size_t *retlen, const u_char *buf)
  {
-@@ -1505,6 +1509,7 @@ static int cfi_amdstd_write_buffers(stru
+@@ -1494,6 +1498,7 @@ static int cfi_amdstd_write_buffers(stru
  
        return 0;
  }
index bce835f86ad7e55ad1e8e257fb0d382b780e17bb..aa24526fd0f623e46b5d4a2a54d5d1c759dde1e7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/nand/Kconfig
 +++ b/drivers/mtd/nand/Kconfig
-@@ -482,4 +482,8 @@ config MTD_NAND_W90P910
+@@ -488,4 +488,8 @@ config MTD_NAND_W90P910
          This enables the driver for the NAND Flash on evaluation board based
          on w90p910.
  
@@ -11,7 +11,7 @@
  endif # MTD_NAND
 --- a/drivers/mtd/nand/Makefile
 +++ b/drivers/mtd/nand/Makefile
-@@ -31,6 +31,7 @@ obj-$(CONFIG_MTD_NAND_BASLER_EXCITE) += 
+@@ -30,6 +30,7 @@ obj-$(CONFIG_MTD_NAND_CM_X270)               += cmx27
  obj-$(CONFIG_MTD_NAND_PXA3xx)         += pxa3xx_nand.o
  obj-$(CONFIG_MTD_NAND_TMIO)           += tmio_nand.o
  obj-$(CONFIG_MTD_NAND_PLATFORM)               += plat_nand.o
index a4b4595b048629572b8525730cf6c568494644d8..487785a9473eaa742a2f713c618e92a4ad9165ad 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -296,6 +296,11 @@ config SPI_TLE62X0
+@@ -365,6 +365,11 @@ config SPI_TLE62X0
          sysfs interface, with each line presented as a kind of GPIO
          exposing both switch control and diagnostic feedback.
  
@@ -14,7 +14,7 @@
  #
 --- a/drivers/spi/Makefile
 +++ b/drivers/spi/Makefile
-@@ -40,6 +40,7 @@ obj-$(CONFIG_SPI_STMP3XXX)           += spi_stmp.
+@@ -54,6 +54,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
  
  # SPI protocol drivers (device/link on bus)
  obj-$(CONFIG_SPI_SPIDEV)      += spidev.o
index e48710ca91b76778158eeb6556e390f20d426e53..2a6edeb185969d58540cfc5e6e6fd0fb79635458 100644 (file)
@@ -17,7 +17,7 @@
        depends on (ARCH_AT91 || AVR32)
 --- a/drivers/spi/Makefile
 +++ b/drivers/spi/Makefile
-@@ -22,6 +22,7 @@ obj-$(CONFIG_SPI_GPIO)                       += spi_gpio.o
+@@ -24,6 +24,7 @@ obj-$(CONFIG_SPI_GPIO)                       += spi_gpio.o
  obj-$(CONFIG_SPI_GPIO_OLD)            += spi_gpio_old.o
  obj-$(CONFIG_SPI_IMX)                 += spi_imx.o
  obj-$(CONFIG_SPI_LM70_LLP)            += spi_lm70llp.o
index 79c6b080f0c942e3d3ee206ba69fa33634f390b4..d2fbc9c764963aaa88c8c3405e3b6128b7703d20 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.33/drivers/leds/Kconfig
-===================================================================
---- linux-2.6.33.orig/drivers/leds/Kconfig     2010-02-28 16:43:15.000000000 +0100
-+++ linux-2.6.33/drivers/leds/Kconfig  2010-02-28 16:47:43.134713224 +0100
-@@ -269,6 +269,13 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -269,6 +269,13 @@ config LEDS_ADP5520
          To compile this driver as a module, choose M here: the module will
          be called leds-adp5520.
  
@@ -16,11 +14,9 @@ Index: linux-2.6.33/drivers/leds/Kconfig
  comment "LED Triggers"
  
  config LEDS_TRIGGERS
-Index: linux-2.6.33/drivers/leds/Makefile
-===================================================================
---- linux-2.6.33.orig/drivers/leds/Makefile    2010-02-28 16:43:15.000000000 +0100
-+++ linux-2.6.33/drivers/leds/Makefile 2010-02-28 16:48:22.946586221 +0100
-@@ -29,6 +29,7 @@
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -29,6 +29,7 @@ obj-$(CONFIG_LEDS_DA903X)            += leds-da903
  obj-$(CONFIG_LEDS_WM831X_STATUS)      += leds-wm831x-status.o
  obj-$(CONFIG_LEDS_WM8350)             += leds-wm8350.o
  obj-$(CONFIG_LEDS_PWM)                        += leds-pwm.o
index 1192d99ee004daa92c6b2f494bf1616d06425a38..575f7bbd89f3d208d8e040ea514ed655e2a811da 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -230,4 +230,12 @@ config GPIO_UCB1400
+@@ -255,4 +255,12 @@ config GPIO_UCB1400
          To compile this driver as a module, choose M here: the
          module will be called ucb1400_gpio.
  
@@ -15,7 +15,7 @@
  endif
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -10,6 +10,7 @@ obj-$(CONFIG_GPIO_MAX7301)   += max7301.o
+@@ -11,6 +11,7 @@ obj-$(CONFIG_GPIO_MAX7301)   += max7301.o
  obj-$(CONFIG_GPIO_MAX732X)    += max732x.o
  obj-$(CONFIG_GPIO_MC33880)    += mc33880.o
  obj-$(CONFIG_GPIO_MCP23S08)   += mcp23s08.o
index 8a834607d2385037bbb48c741d8d62feff4c7bb2..dd4905a07950d45384a56d2fb05e02baaf323280 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -169,6 +169,7 @@ endif
+@@ -181,6 +181,7 @@ endif
  #
  libs-$(CONFIG_ARC)            += arch/mips/fw/arc/
  libs-$(CONFIG_CFE)            += arch/mips/fw/cfe/
@@ -10,7 +10,7 @@
  
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -880,6 +880,9 @@ config MIPS_NILE4
+@@ -877,6 +877,9 @@ config MIPS_NILE4
  config MIPS_DISABLE_OBSOLETE_IDE
        bool
  
index e6c45e50aff2551b627dc3191ae37122b7b262e8..596e6697e70948fb99faa885424ddf2b9332f74c 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.33/arch/mips/kernel/traps.c
-===================================================================
---- linux-2.6.33.orig/arch/mips/kernel/traps.c 2010-02-24 19:52:17.000000000 +0100
-+++ linux-2.6.33/arch/mips/kernel/traps.c      2010-02-28 16:51:35.397204241 +0100
+--- a/arch/mips/kernel/traps.c
++++ b/arch/mips/kernel/traps.c
 @@ -50,6 +50,7 @@
  #include <asm/types.h>
  #include <asm/stacktrace.h>
@@ -10,7 +8,7 @@ Index: linux-2.6.33/arch/mips/kernel/traps.c
  
  extern void check_wait(void);
  extern asmlinkage void r4k_wait(void);
-@@ -1496,6 +1497,8 @@
+@@ -1496,6 +1497,8 @@ void __cpuinit per_cpu_trap_init(void)
        if (cpu_has_mips_r2) {
                cp0_compare_irq_shift = CAUSEB_TI - CAUSEB_IP;
                cp0_compare_irq = (read_c0_intctl() >> INTCTLB_IPTI) & 7;
@@ -19,11 +17,9 @@ Index: linux-2.6.33/arch/mips/kernel/traps.c
                cp0_perfcount_irq = (read_c0_intctl() >> INTCTLB_IPPCI) & 7;
                if (cp0_perfcount_irq == cp0_compare_irq)
                        cp0_perfcount_irq = -1;
-Index: linux-2.6.33/arch/mips/include/asm/time.h
-===================================================================
---- linux-2.6.33.orig/arch/mips/include/asm/time.h     2010-02-24 19:52:17.000000000 +0100
-+++ linux-2.6.33/arch/mips/include/asm/time.h  2010-02-28 16:49:18.925959821 +0100
-@@ -52,6 +52,7 @@
+--- a/arch/mips/include/asm/time.h
++++ b/arch/mips/include/asm/time.h
+@@ -52,6 +52,7 @@ extern int (*perf_irq)(void);
   */
  #ifdef CONFIG_CEVT_R4K_LIB
  extern unsigned int __weak get_c0_compare_int(void);
index 894eed1e5b95c0e2b1096245ef11bf0ded63f470..1ce438080ba159b453026a66b7179d593d32bfc4 100644 (file)
@@ -32,7 +32,7 @@
        return res;
  }
 @@ -100,22 +117,6 @@ static int c0_compare_int_pending(void)
-       return (read_c0_cause() >> cp0_compare_irq) & 0x100;
+       return (read_c0_cause() >> cp0_compare_irq_shift) & (1ul << CAUSEB_IP);
  }
  
 -/*