prefer http downloads over svn/git checkouts, remove git dependency
authorFelix Fietkau <nbd@openwrt.org>
Fri, 16 Nov 2007 04:10:01 +0000 (04:10 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 16 Nov 2007 04:10:01 +0000 (04:10 +0000)
SVN-Revision: 9567

include/download.mk
include/prereq-build.mk

index 3c7cb7e77b96d4b4cee813ea8e6ae3ade877ab90..23f2996ed14004436cf345c12e2be54798160890 100644 (file)
@@ -39,9 +39,7 @@ define DownloadMethod/default
 endef
 
 define wrap_mirror
-       @$(if $(CONFIG_LOCALMIRROR),$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ) \
-       ( $(1) ) \
-       $(if $(CONFIG_LOCALMIRROR),, || $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x")
+       @$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "x" || ( $(1) )
 endef
 
 define DownloadMethod/svn
index 9b77a1baf70b32828aaeb6f0ace064b08fc031fc..1e448d393f699f121ee3cb21ffc55a835adb8b93 100644 (file)
@@ -119,14 +119,6 @@ $(eval $(call Require,gnutar, \
        Please install GNU tar. \
 ))
 
-define Require/git
-       which git-clone
-endef
-
-$(eval $(call Require,git, \
-       Please install git. \
-))
-
 $(eval $(call RequireCommand,svn, \
        Please install the subversion client. \
 ))