include: force a kernel-generated cpio removal and rebuild
authorFlorian Fainelli <florian@openwrt.org>
Mon, 1 Jul 2013 20:52:00 +0000 (20:52 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 1 Jul 2013 20:52:00 +0000 (20:52 +0000)
Make sure that the kernel rebuilds the initramfs cpio archive file by
deleting it before so we get it re-generated properly.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 37125

include/kernel-defaults.mk

index ca520f55c95a6a86c620d02ccfc433c062642a48..607c8211b8a941aab0fa1d8bb583f9b9540fe8a5 100644 (file)
@@ -144,6 +144,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
 define Kernel/CompileImage/Initramfs
        $(call Kernel/Configure/Initramfs)
        $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),,rm -f $(TARGET_DIR)/init)
+       rm -rf $(KERNEL_BUILD_DIR)/usr/initramfs_data.cpio*
        +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME))
        #")
        #")