hostapd: properly enable 802.11w support
authorFelix Fietkau <nbd@openwrt.org>
Thu, 27 Aug 2015 12:43:22 +0000 (12:43 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 27 Aug 2015 12:43:22 +0000 (12:43 +0000)
Add CONFIG_IEEE80211W variable to DRIVER_MAKEOPTS so that 802.11w
support is properly compiled in full variant.

This fixes #20179

Signed-off-by: Janusz Dziemidowicz <rraptorr@nails.eu.org>
SVN-Revision: 46737

package/network/services/hostapd/Makefile

index 3dff7b4852f8e428ebe3b0accf1107872677af11..c16cb11294b4f61e84df3325eb1e023992d7c600 100644 (file)
@@ -71,7 +71,7 @@ DRIVER_MAKEOPTS= \
        CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
 
 ifeq ($(LOCAL_VARIANT),full)
-  CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
+  DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k)
 endif
 
 ifneq ($(LOCAL_TYPE),hostapd)