package/grub: fix build issues under 64bit FreeBSD
authorAlexandros C. Couloumbis <alex@ozo.com>
Thu, 30 Sep 2010 14:48:31 +0000 (14:48 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Thu, 30 Sep 2010 14:48:31 +0000 (14:48 +0000)
SVN-Revision: 23162

package/grub/Makefile

index f3dd171141b9436474561970b8a5762d2d685af8..ee527be13f4adc22360e8ed8a0088600932a59ce 100644 (file)
@@ -37,10 +37,6 @@ MY_CONFIGURE_ARGS += \
        --disable-hercules \
        --without-curses \
 
-ifeq ($(HOST_OS),FreeBSD)
-  MY_CONFIGURE_ARGS += --build=$(GNU_HOST_NAME) --host=$(GNU_TARGET_NAME) --target=$(GNU_TARGET_NAME)
-endif
-
 MY_CONFIGURE_VARS += \
        grub_cv_prog_objcopy_absolute=yes \
 
@@ -53,6 +49,14 @@ ifeq ($(HOST_OS),Darwin)
   HOST_CFLAGS += $(call host-cc-option,-fnested-functions)
 endif
 
+ifeq ($(HOST_OS),FreeBSD)
+  ifeq ($(HOST_ARCH),amd64)
+    HOST_CFLAGS += $(call host-cc-option,-m32)
+    HOST_CFLAGS += $(call host-cc-option,-B/usr/lib32)
+    HOST_CFLAGS += $(call host-cc-option,-L/usr/lib32)
+  endif
+endif
+
 HOST_CFLAGS += $(call host-cc-option,-fno-stack-protector)
 HOST_CFLAGS += $(call host-cc-option,-U_FORTIFY_SOURCE)