atheros: remove static gpio_request() from board setup and include generic kmod-gpio...
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 2 May 2013 11:46:53 +0000 (11:46 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 2 May 2013 11:46:53 +0000 (11:46 +0000)
This change is based on a patch by Karl Palsson <karlp@remake.is>
See http://patchwork.openwrt.org/patch/3536/.

SVN-Revision: 36513

target/linux/atheros/Makefile
target/linux/atheros/patches-3.8/100-board.patch

index c7e9f84e438b0fb89ce8bc62949ae010c03db9b8..1748f2447410fb2f9bb8a950264a887000acce62 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,7 @@ LINUX_VERSION:=3.8.11
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Atheros SoC boards
index 56c1f6943d4cf40f0602066ba3fcae26f6d080c9..8663156ade0c843ba073aa53687d468f2f94fd40 100644 (file)
 +
 --- /dev/null
 +++ b/arch/mips/ar231x/ar2315.c
-@@ -0,0 +1,694 @@
+@@ -0,0 +1,692 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
 +      if (!is_2315())
 +              return;
 +
-+      gpio_request(AR2315_RESET_GPIO, "reset");
-+
 +      /* Clear any lingering AHB errors */
 +      config = read_c0_config();
 +      write_c0_config(config & ~0x3);