6to4: add support for native IPv6 prefix handling
authorSteven Barth <cyrus@openwrt.org>
Tue, 15 Jan 2013 13:08:10 +0000 (13:08 +0000)
committerSteven Barth <cyrus@openwrt.org>
Tue, 15 Jan 2013 13:08:10 +0000 (13:08 +0000)
SVN-Revision: 35172

package/network/ipv6/6to4/Makefile
package/network/ipv6/6to4/files/6to4.sh

index f29571d86c87d4ee6ec3faa3a1bd7db254db70d7..72906fba5bd323f196fbaf9213222120762e287a 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6to4
-PKG_VERSION:=11
+PKG_VERSION:=12
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 145f78a23987e14d2f94a9a182683b2b120ddf41..6f2fbd840cca39469228efe1a3c02712a541e3d7 100755 (executable)
@@ -63,6 +63,7 @@ proto_6to4_setup() {
 
        proto_init_update "$link" 1
        proto_add_ipv6_address "$local6" 16
+       proto_add_ipv6_prefix "$prefix6::/48"
        proto_add_ipv6_route "::" 0 "::192.88.99.1"
 
        proto_add_tunnel