mips: do not use the prefetch instruction on R4K (MIPS32_R1), the ISA does not implem...
authorFelix Fietkau <nbd@openwrt.org>
Sat, 11 Jul 2009 02:30:19 +0000 (02:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 11 Jul 2009 02:30:19 +0000 (02:30 +0000)
SVN-Revision: 16771

target/linux/atheros/patches-2.6.30/100-board.patch
target/linux/generic-2.6/patches-2.6.28/025-mips_r4k_no_prefetch.patch [new file with mode: 0644]
target/linux/generic-2.6/patches-2.6.30/026-mips_r4k_no_prefetch.patch [new file with mode: 0644]

index 052e887d25bdbe1ecf408847af4582665f8f7ca6..c063fa348f55cc1d4df2e081c61fa29bb378d4c8 100644 (file)
@@ -20,7 +20,7 @@
  config MIPS_COBALT
        bool "Cobalt Server"
        select CEVT_R4K
-@@ -632,6 +645,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
+@@ -633,6 +646,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
  
  endchoice
  
@@ -30,7 +30,7 @@
  source "arch/mips/jazz/Kconfig"
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -290,6 +290,13 @@ libs-$(CONFIG_MIPS_XXS1500)       += arch/mips
+@@ -283,6 +283,13 @@ libs-$(CONFIG_MIPS_XXS1500)       += arch/mips
  load-$(CONFIG_MIPS_XXS1500)   += 0xffffffff80100000
  
  #
diff --git a/target/linux/generic-2.6/patches-2.6.28/025-mips_r4k_no_prefetch.patch b/target/linux/generic-2.6/patches-2.6.28/025-mips_r4k_no_prefetch.patch
new file mode 100644 (file)
index 0000000..6e26062
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -991,7 +991,6 @@ config CPU_MIPS32_R1
+       bool "MIPS32 Release 1"
+       depends on SYS_HAS_CPU_MIPS32_R1
+       select CPU_HAS_LLSC
+-      select CPU_HAS_PREFETCH
+       select CPU_SUPPORTS_32BIT_KERNEL
+       select CPU_SUPPORTS_HIGHMEM
+       help
diff --git a/target/linux/generic-2.6/patches-2.6.30/026-mips_r4k_no_prefetch.patch b/target/linux/generic-2.6/patches-2.6.30/026-mips_r4k_no_prefetch.patch
new file mode 100644 (file)
index 0000000..e2fb97e
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -1036,7 +1036,6 @@ config CPU_MIPS32_R1
+       bool "MIPS32 Release 1"
+       depends on SYS_HAS_CPU_MIPS32_R1
+       select CPU_HAS_LLSC
+-      select CPU_HAS_PREFETCH
+       select CPU_SUPPORTS_32BIT_KERNEL
+       select CPU_SUPPORTS_HIGHMEM
+       help