target/imagebuilder: add missing package index (fixes #16675)
authorFelix Fietkau <nbd@openwrt.org>
Mon, 2 Jun 2014 13:27:31 +0000 (13:27 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 2 Jun 2014 13:27:31 +0000 (13:27 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 40968

target/imagebuilder/Makefile

index 5dd95eabbd82f3712d039ef885bf8cf3f288b8b8..e52ca623ee46db88fba5d49571c5d5756888bcc5 100644 (file)
@@ -50,6 +50,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
          | $(XARGS) rm -rf
        find $(STAGING_DIR_HOST)/bin -maxdepth 1 -type f -perm -u=x \
          | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin
+       $(MAKE) -C $(PKG_BUILD_DIR) package_index
        $(TAR) c -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
 
 download: