toolchain/gcc: pass proper flags for arm hard float build
authorLuka Perkov <luka@openwrt.org>
Mon, 14 Jul 2014 20:28:53 +0000 (20:28 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 14 Jul 2014 20:28:53 +0000 (20:28 +0000)
This fixes eglibc build failure. More information about the bug can be found on
the link below.

https://gcc.gnu.org/bugzilla/show_bug.cgi?id=61796

Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 41657

toolchain/gcc/common.mk

index 5dfbc488cd46d66ff1c8f9800c61f36be6645812..e8ca778e6e27e1632ef24273502a73960a41a562 100644 (file)
@@ -162,6 +162,13 @@ ifneq ($(GCC_ARCH),)
   GCC_CONFIGURE+= --with-arch=$(GCC_ARCH)
 endif
 
+ifneq ($(CONFIG_SOFT_FLOAT),y)
+  ifeq ($(CONFIG_arm),y)
+    GCC_CONFIGURE+= \
+               --with-float=hard
+  endif
+endif
+
 GCC_MAKE:= \
        export SHELL="$(BASH)"; \
        $(MAKE) \