imx6: add default profile
authorLuka Perkov <luka@openwrt.org>
Wed, 2 Oct 2013 00:33:49 +0000 (00:33 +0000)
committerLuka Perkov <luka@openwrt.org>
Wed, 2 Oct 2013 00:33:49 +0000 (00:33 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38282

target/linux/imx6/Makefile
target/linux/imx6/profiles/100-Generic.mk [new file with mode: 0644]

index b9b2062ef32bccf0760c78e30cdcffbb49b7166e..3af424e64c3b95c8c805122d1af637518e5b66b0 100644 (file)
@@ -20,7 +20,6 @@ include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="zImage dtbs"
 
-DEFAULT_PACKAGES += \
-       kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy uboot-envtools
+DEFAULT_PACKAGES +=
 
 $(eval $(call BuildTarget))
diff --git a/target/linux/imx6/profiles/100-Generic.mk b/target/linux/imx6/profiles/100-Generic.mk
new file mode 100644 (file)
index 0000000..91ca369
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic (default)
+  PACKAGES:= \
+       kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy \
+       uboot-envtools
+endef
+
+define Profile/Generic/Description
+ Package set compatible with most Freescale i.MX 6 based boards.
+endef
+
+$(eval $(call Profile,Generic))